Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(36 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

xref: ok or fubar
show user profile  advance-software
so, just tried an experiment with xref-scene which I *thought* worked sanely.

blank scene - create teapot.
save as object,max

reset.
create dummy.
xref scene, select object.max, bind to the dummy,
should now be able to move the xref'd teapot.

on max9, if I now create a second dummy to try to bind a second xref'd teapot, it just reassigns the first xref to the new dummy. ie. only one reference per scene apparently which is fucked up. I might want more than one teapot (or whatever).

is xref/scene working sanely in later versions ?

edit: sorted. thanks nik.
read 575 times
7/13/2012 7:21:07 PM (last edit: 7/14/2012 12:11:39 PM)
show user profile  Nik Clark
Works fine on max 2013 for me.



read 540 times
7/13/2012 8:47:21 PM (last edit: 7/13/2012 8:47:21 PM)
show user profile  advance-software
also fine on max9 - checked again. phew. thought I'd missed a gotcha.

you have to add the scene again in the xref scene dialog then bind the new one & it works.

not as intuitive as it could be but that'll do.

thanks nik.

ideally you could just xref in a scene or part of one & just move it around without having to bind it to anything (as you can in other apps) but that's a max quirk. fortunuately only a little one.

next up - rewriting our docs to remove all that container nonsense. this is much easier.

can't instance xref-scene'd stuff in 9. hopefully they've fixed that in later versions. if not, an instance xref-scene script or plugin is probably possible. would be nice if all this 'just worked'.
read 535 times
7/13/2012 8:54:07 PM (last edit: 7/13/2012 9:04:59 PM)
show user profile  advance-software
got xref-scene export working.

can't figure out how to get the transform between the xref'd scene & the thing it's bound to - will ask ad.

for now (with our tools), the thing you're binding to has to be at the origin when you bind as would be the case with an implicit node if they'd done this properly (thus you wouldn't need to bind as it'd just be another node in the scene graph)

found a ms duplicate xref-scene script whilst searching that might be helpful.

http://mertens3d.com/blog/?p=57


max docs for the interested : xref scene docs

can probably drop a layer over this in maxscript or the sdk to auto-create a node at the origin & bind whatever you're x-ref'ing directly to it automatically to simplify the process.
read 496 times
7/14/2012 8:54:28 PM (last edit: 7/14/2012 9:07:59 PM)
show user profile  advance-software
putting together a tools plugin to simplify all this. with it xrefs will 'just work' but you can use the standard max procedure or something scripted instead if you like.

it turns out max supports xref scene in older versions than I thought so my max6 isn't a bag of shite after all :) yay.
read 463 times
7/15/2012 3:46:31 PM (last edit: 7/15/2012 3:54:26 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org