Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(36 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

Weird raytrace shadows...
show user profile  graphix72
I got a direct light with raytrace shadows, using Mental Ray. The shadows the zeppelin is casting on itself are white and chunky... any idea why? When I turn off raytrace shadows, they go away.

Thanks.


read 526 times
3/20/2009 6:39:15 AM (last edit: 3/20/2009 6:39:15 AM)
show user profile  Dejitarujin
Wow. Interesting!

Check that the shadow is set to black, and a positive number. Not sure if it'll even go negative, but it can't hurt to check.
~~~
Specialty: Non-organic modelling and effects.
Setup: 3D Studio 2010 with finalRender.
Rig: No, no I can't.
read 513 times
3/20/2009 7:22:50 AM (last edit: 3/20/2009 7:22:50 AM)
show user profile  graphix72
I do have everything as always. Here are the settings:

Maybe of note is that the zeppelin including the tail fins is one single object, not multiple parts. Also to mention, the zeppelin has several UVW Mappings, one for the general texture and other ones for decals on the sides. But I don't think any of this should affect the shadows in this way.


read 497 times
3/20/2009 8:00:49 AM (last edit: 3/20/2009 8:00:49 AM)
show user profile  graphix72
I've been messing with the material editor, I'm using a composite material - base for the zeppelin and additional materials for the decals. If I turn off the decals and keep just the base material, the shadows are fine. However, if I turn on any decals, the shadows become transparent... or white. The decals all have opacity masks, and planar projection maps, and I turned tiling off. It's really strange how it's doing this... anyone have any idea at all??

EDIT: Another item of note, in the Mat editor, if I turn off the decal's opacity map, the strangeness goes away. But if I turn on the opacity map, the shadows become transparent again. It has something to do with the composite material and opacity map. I have tiling turned off, by the way.

EDIT 2: When I switch from Mental Ray to Default Scanline Renderer, the problem goes away.


read 491 times
3/20/2009 8:19:31 AM (last edit: 3/20/2009 8:43:56 AM)
show user profile  Dejitarujin
I remember a short time ago, someone was having similar issues using a Composite map, so I'm fairly certain that's the problem. I'm not sure what the solution was, I'll look back and find it...

Edit: The solution was to use a Blend map instead of Composite.
~~~
Specialty: Non-organic modelling and effects.
Setup: 3D Studio 2010 with finalRender.
Rig: No, no I can't.
read 479 times
3/20/2009 8:54:04 AM (last edit: 3/20/2009 8:56:39 AM)
show user profile  graphix72
I'm using the composite material because it lets me assign different maps to different material IDs, and that's how I can position decals on the side of the zeppelin, with separate mappings. I'm pretty sure blend map won't let me do that... am I wrong? I'll go dig up the help file on this. If I'm right, what other way is there to put decals on an object?


read 466 times
3/20/2009 10:08:34 AM (last edit: 3/20/2009 10:08:34 AM)
#Maxforums IRC
Open chat window


Support Maxforums.org