Forum Groups
  All forums
    Help & Feedback
      Work in progress
      Finished Art
      Non-Max related

Maxunderground news unavailable

Vray distributed rendering particles, missing buckets?
show user profile  9krausec
Morning all.

Vray distributed rendering (one when rendering an animation, stills work fine) is giving me some grief as it is missing buckets of my particle system.

To my knowledge this isn't a conventional "asset missing" due to not being tied to a UNC location, as I know it...

Unable to display content. Adobe Flash is required.

Any ideas guys? I am using Maya, but I figured some of you may still have an idea as to where to start trouble shooting.


Edit: The Particle system was not cached out, would calculating at render time be an issue? I've been having cache issues lately with my setup so that's why my particle system wasn't cached.

- Portfolio-

read 962 times
8/27/2015 4:08:32 PM (last edit: 8/27/2015 4:39:37 PM)
show user profile  donvella
just beware that anything at all local is likely to be missed by vray dr. try cache everything to the shared drive (particles, ies lights, etc), make sure all nodes have access. All nodes are running dr as admin and all nodes have rendered at least 1 job via backburner

read 943 times
8/28/2015 12:26:08 AM (last edit: 8/28/2015 12:26:41 AM)
show user profile  9krausec
So here's the deal. I had an issue hooking my particle system up to the cache that it produced BECAUSE my particle system's velocity is driven by a Maya's fluid system. So, it can only have one driving force to it (fluid system or cached particle data).

I kept on doing the same shit... Trying to produce a particle cache and then attempting to connect it (because after it was produced it wouldn't take)... then I had the "ah-ha" moment and disconnected it from the fluid system and it worked! (A-duh).

I think I just solved multiple problems at one time... With a cached particle system now I don't need the cached fluid system that was initially driving it's velocity. So stick the particle cache in a shared UNC location and BAM.

Sometimes it just takes you a day of banging your head against a wall to figure it out. All good guys. Many thanks.

- Portfolio-

read 933 times
8/28/2015 2:07:58 AM (last edit: 8/28/2015 2:07:58 AM)
show user profile  9krausec
@Donvella - All nodes have rendered at least 1 job via backburner? I'm not even using backburner, just Vray DR (which has worked fine without BB for animations up til this point).

Just wondering because even with cached particles, the cache being stored on a UNC drive, I'm still getting holes in my render. Any other ideas gang?

- Portfolio-

read 905 times
8/31/2015 3:54:08 PM (last edit: 8/31/2015 3:54:08 PM)
show user profile  donvella
yeah, wierd right.

installation notes:
If you create a fresh install of 3ds Max on a machine, you will need run at least one Backburner job with this machine as a server, before you can use the machine for distributed rendering.

read 888 times
9/1/2015 4:07:50 AM (last edit: 9/1/2015 4:07:50 AM)
show user profile  9krausec
Super weird. I'll need to check if there's something about that for Maya tomorrow too.

- Portfolio-

read 884 times
9/1/2015 5:14:53 AM (last edit: 9/1/2015 5:14:53 AM)
show user profile  Bolteon
I've read that too but in our testing to get the software setup for cloud rendering on our platform; we never ran a BB job.

I believe that requirement may be outdated, though still on the help guides and still being touted by support at Chaosgroup.


Side note, the issue in this thread is most always a permissions issue on being able to reach/read the files needed.

Vray 3?

-Marko Mandaric

read 880 times
9/1/2015 5:57:15 AM (last edit: 9/1/2015 5:58:04 AM)
show user profile  donvella
I second that on the permissions side, were having same issues. we put our assets on a new NAS and no problems so far. We dont use UNC paths but I hear this used to help in the past.

read 874 times
9/1/2015 7:06:09 AM (last edit: 9/1/2015 7:06:09 AM)
show user profile  9krausec
I didn't want to delve too far into the Maya side of things but posted below is a brief of how I have things setup.. This is not a permissions issue (or at least a standard asset/UNC permissions issue).

The only reason I say that is because it came straight from Vlado-

"The particle data is exported in the vrscene itself, the slaves don't need to access the cache."

Below is the brief-

So below is an example of what I was trying to do-

Apply the Per-Particle attribute export (vray) to my particle shape to get the information-

Then go into my hypershade and use a particleSamplerInfo node to push what I thought were those values to the material I had applied to the particles-

ParticleSamplerNode is the correct way to go about this...
Straight from the documentation-

I guess my question is if I'm hooking up the particleSamplerNode correctly. If not then there might not be any internal issue... What is confusing is that I'm getting the appropriate results when rendering a single frame. Exactly what I'd expect and want... Once I push it to render an animation however, then I start missing buckets.... Even on a still frame the slaves render everything out correctly (which is the confusing part).

- Portfolio-

read 864 times
9/1/2015 3:08:57 PM (last edit: 9/1/2015 3:09:35 PM)
show user profile  9krausec
My next step in troubleshooting is two parts I suppose.. Do not use any of the Extra Vray Attributes and see if the problem persists with just the particle system (which from earlier test the issue went away) and then also attempt to recreate the issue in a new Maya scene.

- Portfolio-

read 860 times
9/1/2015 3:11:14 PM (last edit: 9/1/2015 3:11:14 PM)
#Maxforums IRC
Open chat window