Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(36 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

UVW Unwrapping - changes made here keep reverting back
show user profile  tileboy
Hi,

I've been doing a tutorial modeling houses, and using uvw unwrapping to do the faces that extend inward at windowsills and door archways. There doesn't seem to be any problem creating the new faces using this technique, but I keep going back and finding that it's reverting back to how it looks right after extending the face polygons inward. Is there some reason why it's doing this that I don't know about? Why isn't it saving the changes I make - after all, I do press save and everything else is getting saved right.
read 436 times
11/6/2011 4:33:36 AM (last edit: 11/6/2011 4:33:36 AM)
show user profile  Garp
What do you do with your unwrap modifier once you've done your mapping? Do you leave it in the stack, collapse it or remove it?
Also, are you using the same map channel in the material and the unwrap mod?




read 432 times
11/6/2011 4:51:50 AM (last edit: 11/6/2011 4:51:50 AM)
show user profile  tileboy
The modifier is still in the stack, but I have been collapsing it - I had no idea this would do anything. As far as your question about map channels - I'm not really sure about how to tell if it's the same channel or not. When I'm in the uvw editor, the same image from the material editor is showing up in the background of the uvw editor, where I've been shaping and positioning the red boxes as to what I want displayed in the faces that extrude inwardly. I hope this information answers the question about whether they're on the same map channel.
read 413 times
11/6/2011 8:24:47 PM (last edit: 11/6/2011 8:24:47 PM)
show user profile  Garp
You don't need to collapse the unwrap. Just make sure it stays there.

In the Coordinates rollout of your map, you should have the mapping method set to Explicit Map Channel and the map channel number maching the one in the unwrap modifier (Channel rollout).




read 407 times
11/6/2011 8:37:01 PM (last edit: 11/6/2011 8:37:01 PM)
show user profile  tileboy
Mapping method is set to explicit map channel and the map channel #'s are matching, but my uvw unwrapping still keeps disappearing. I just deleted some of the faces on the house I'm modeling and boom - the uvw unwrapping gone immediately. As long as no changes are made, the uvw unwrapping does hold up though.
read 398 times
11/6/2011 11:01:55 PM (last edit: 11/6/2011 11:01:55 PM)
show user profile  K-tonne
map when the model is finalised

Website and Portfolio

read 389 times
11/7/2011 12:07:53 AM (last edit: 11/7/2011 12:07:53 AM)
show user profile  Garp
My thought exactly :)
In the meantime, try with the Preserve UVs option checked in the Edit Geometry rollout.




read 386 times
11/7/2011 12:21:27 AM (last edit: 11/7/2011 12:21:27 AM)
show user profile  tileboy
Thanks for all the help. I'm afraid that unwrapping last probably is the only option. Maybe it's just a design flaw in the software itself, who knows.

Photobucket
read 375 times
11/7/2011 4:25:15 AM (last edit: 11/7/2011 4:26:12 AM)
show user profile  scotchforgothispasswordagain
Sounds like you're trying to adjust the mesh at the base level underneath the Unwrap modifier. If so, you're essentially changing the inputs that the Unwrap mod is receiving, and then complaining that Unwrap can't correctly guess what to do with the new mesh you're sending it. Remember that the stack gets evaluated from the bottom up, so anything you change at one level affects everything above it, in order. For stuff like selection sets affecting Bend modifiers (for example) this is useful and desirable behaviour, but an Unwrap modifier just applies UVW values to the specific verts you pass to it, so if you alter the base mesh then you re-order all the verts and Unwrap has no way of tracking that, so it resets.

If you want to model and unwrap as you go, either collapse the unwrap each time before doing any more modelling, or else add an Edit Poly mod above each Unwrap and model in that (which would be pointless in most cases, but would work).
read 360 times
11/7/2011 4:19:24 PM (last edit: 11/7/2011 4:19:24 PM)
show user profile  tileboy
Thanks for this additional info - I hope I'm not coming across as a complainer though, I'm just very new to 3d Max and need lots of help. I actually understand now why this is happening and how to work around this issue.
read 349 times
11/7/2011 9:01:37 PM (last edit: 11/7/2011 9:01:37 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org