Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography



Maxunderground news unavailable

UV channel+unity5 problem
show user profile  sheheryar_noor
I got some models with textures.
Below is the setting

Either i change the material map channel to 2 or change the uv map channel to 1 in both cases texture is messed up. I wanted to copy current texture look to channel 1. I tried copying pasting uvs, used script to copy and paste uv channel but didn't work every time texture for channel 1 was messed up.
Applied Unwrap Uvw with channel 1 > editable poly and exported as fbx. Same fbx same texture looks fine in Unity 4 but in unity 5 it is messed up. http://prntscr.com/c6cmgi
http://prnt.sc/c6cqsl

Anyone know what causing this?
read 273 times
8/16/2016 12:32:58 PM (last edit: 8/16/2016 12:48:20 PM)
show user profile  Dave
I don't really understand the issue. But here's some thoughts:

In the picture above you're displaying the texture on map channel 1. Which means the viewport preview you're looking at is showing you map channel 1. I only say this, because over on the right you've highlighted map channel 2, but you can edit that until the cows come home, it won't change your texture/viewport preview, because that's set to channel 1.

Secondly, you don't need scripts to copy/move/delete map channel data. Simply go to Tools > Channel Info and a window will pop-up. If you do have 2 map channels then you'll see: "1:map" and "2:map" in the ID list. If you don't see "2:map" then you don't have a 2nd map channel.

To copy one from another, just right click it, copy, and then paste it to another. You can also right click and choose "clear" to wipe a map channel.

"I flew over Egypt once"

read 250 times
8/17/2016 6:31:44 PM (last edit: 8/17/2016 6:31:44 PM)
show user profile  sheheryar_noor
The channel on right if i change it to 1 it effects the result in viewport. Thanks for the channel info. It was dotnet frame issue :) Same fbx and texture was working fine on Unity4 and Unity 5 on two diff laptops, but same version of unity(5) on another laptop was having this issue. I am not sure if it was dotnet issue or not but that's what solved it :)
read 231 times
8/19/2016 11:23:00 AM (last edit: 8/19/2016 11:23:00 AM)
show user profile  HANZZ
You might not understand how this all works together. apply a UV modifier and if you want it to have a DIFFERENT placement of the texture on the model, set it to 2. That UV modifier, if set to 2, means the material editor and material map channel need to be set at 2 as well so max will look for X texture in map channel 2, and also in uv modifier channel 2.

 photo MorgothArisenSig_zpsup4yjp7o.jpg

read 222 times
8/19/2016 12:27:53 PM (last edit: 8/19/2016 12:27:53 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org