Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(37 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

Strange shadows on mesh
show user profile  Jedo
Hi, I am a newbie working on a mesh of a boot from a game (Skyrim). The boot on the left is how the mesh looked as I was working on it and then the mesh on the right is how it suddenly started looking just a few modifications later. I don't know where those strange shadows came from but it seems that they do not disappear if I move the geometry.

Can someone in really simple terms explain what could be wrong? Many thanks



I tried adding a smooth modifier and change values (as I know oversmoothing can make the mesh look weird like that), but that didn't help. Maybe I can reset the whole thing somehow?



read 349 times
1/15/2012 2:54:52 AM (last edit: 1/15/2012 3:04:50 AM)
show user profile  jareu
looks to me like some of the normals aren't matching up.

Polygons, in 3D are one sided. A normal is a vector, which is perpendicular to the polygon. It shows what direction the polygon is facing and is used in shading. If the normal vector is facing roughly the same way as the lighting, then it will not be lit and will be rendered dark. If the normal is facing the light, then it will be lit by that light.

It appears that your boot model has some 'normal' issues, but the smoothing groups are blending between the lit and unlit polygons, giving that patchy look.

To confirm this, convert to an editable poly, select all the faces, clear all smoothing groups and then give it another look. You should see some very black squares and some grey ones.

To fix it, either apply a 'normal' modifier and check 'Unify Normals' uncheck 'Flip Normals' or you can go into edit poly, select each dark polygon and hit the 'flip' button.



He who says it cannot be done is interrupting the man doing it.

read 321 times
1/15/2012 3:19:44 AM (last edit: 1/15/2012 3:22:41 AM)
show user profile  Jedo
Hmmm.. I tried clicking on "clear all" under smoothing groups but that had exactly 0 effect.

Also I tried unifying normals via the modifier and that didn't do anything either.


Don't know if it helps if I say that I only get this problem with imported models. If I make my own mesh I never have a problem, but I import one of the game's models and after a few modifications something snaps, almost at random it seems.
read 295 times
1/17/2012 7:49:03 AM (last edit: 1/17/2012 8:28:38 AM)
show user profile  jareu
If you want to upload the model to megaupload.com I can check it out for ya.



He who says it cannot be done is interrupting the man doing it.

read 288 times
1/17/2012 8:28:37 AM (last edit: 1/17/2012 8:28:37 AM)
show user profile  Jedo
Ha! Thank you, that fixed the problem.

Don't know why I haven't thought of it before, but I exported the object with all the extras deselected (intending to upload it) and then imported it back in and the normals are fine...for now at least.

I am not a pro but my self-diagnosis is that one of the modifiers imbedded into the mesh when I imported it from the game went crazy when I tried to modify the geometry. I just wish I knew what.


IMPORTANT EDIT: I came back here a year later to say that my solution was a bit silly and just applying a normal modifier did not always work. The easiest way I found to fix this problem is to apply a normal modifier with the boxes for "unify normals" and "flip normals" both checked! This will turn the mesh black. Now collapse the normal modifier (right click and collapse all or collapse to) then add the normal modifier again and check both boxes again. Now the mesh should look normal.
read 281 times
1/17/2012 9:13:13 PM (last edit: 5/3/2013 3:44:56 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org