Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography



Maxunderground news unavailable

Spline interpolation steps. Keep changing on attach.
show user profile  Dave
Pretty simple issue.

2 editable splines. One has steps of 1, the other has steps of 0.

I can't attach them together without either steps becoming 1 for all, or 0 for all. I really just need to attach the splines "as they are" and ignore interpolation. I swear I've done this a thousand times before, but it's just not having any of it today.

A little bit more info: I'm using rectangles and circles. Some circles need a step of 1, but the tiny ones are set to 0. So when I attach the "bigger" ones to the small ones, the smaller ones get too detailed, and the other way around results in my larger circles becoming 4 sided.

Edit
Solved. Sort of.

I played around with the verts of my splines, setting them to cornered/bezier cornered. And have managed to attach them without anything changing. I can't remember exactly what I changed though.

"I flew over Egypt once"

read 387 times
2/2/2015 4:18:44 PM (last edit: 2/2/2015 4:22:37 PM)
show user profile  herfst1
That's how it's always worked for me. Just like using editable poly, whatever you attach to it will adopt it's modifiers (and interpolation is like a tesselate or turbosmooth modifier).

[edit] saw your edit after I posted. That's a cool trick, but I'm pretty sure the mesh topology will still be as dense when you convert it to editable poly.
read 381 times
2/2/2015 4:23:33 PM (last edit: 2/2/2015 4:24:41 PM)
show user profile  Dave
Nón, because I'm not using any sort of "adaptive" mode, the spline points = vertices. All is well after conversion to edit poly.

"I flew over Egypt once"

read 375 times
2/2/2015 4:25:36 PM (last edit: 2/2/2015 4:25:36 PM)
show user profile  herfst1
Cool. Will try that out sometime, could speed up workflow.
read 371 times
2/2/2015 4:28:49 PM (last edit: 2/2/2015 4:28:49 PM)
show user profile  herfst1
Actually, do you know a good way to make the splines weld when converted to editable poly. e.g. you make a T or Y shape, it doesn't weld properly.
read 369 times
2/2/2015 4:30:50 PM (last edit: 2/2/2015 4:31:39 PM)
show user profile  Dave
Not sure, I mean I always make sure my spline-verts are welded before any conversion. Watch out for the "fuse" thing though, I'm pretty sure that just moves verts to the same space and won't actually weld them.

"I flew over Egypt once"

read 357 times
2/2/2015 4:48:20 PM (last edit: 2/2/2015 4:48:20 PM)
show user profile  herfst1
Yeah, that's exactly my conclusion. Well hopefully max will integrate some formula within the next 5-10 years that will fix this.
read 353 times
2/2/2015 5:37:48 PM (last edit: 2/2/2015 5:37:48 PM)
show user profile  Garp
There's nothing to fix. Splines do not branch, so only two end verts can be welded. Fuse is there to set vertices at the same location and avoid mesh errors when building surfaces.




read 350 times
2/2/2015 5:45:31 PM (last edit: 2/2/2015 5:45:31 PM)
show user profile  herfst1
But zbrush's qremesher does fix it. Only trouble is it tends to spiral right now.
read 345 times
2/2/2015 7:16:06 PM (last edit: 2/2/2015 7:16:06 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org