Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography



Maxunderground news unavailable

Spline import from dxf
show user profile  htt_75@yahoo.com
I import a dxf file that has some spline in it. When it brought into 3ds max the spline are not smooth no matter what i did. I apply bezier, bezier corner, smooth to the vertex but no effect?
Any idea?

read 1300 times
8/31/2009 3:06:54 PM (last edit: 8/31/2009 3:06:54 PM)
show user profile  nm8r
Select the spline
Go to Modify
Select Sub-Object - Segment
Select all the spline's segments you want smooth
Right Click - On the upper left Quad Menu - make sure "Curve" is checked
Select Sub-Object - Vertex then change the vertices to Smooth or Bezier
Done

read 1275 times
9/1/2009 12:35:47 PM (last edit: 9/1/2009 12:36:41 PM)
show user profile  Mashedpot8er
Hi there, I do it a different way to nm8r. select your spline and go to the modifier panel. open up the interpolation drop down and either set the steps higher, or just tick adaptive. This should fix it. If it doesn't maybe look at your import options and have a play with the smooth angle. Or do what nm8r said :)






Cad Monkey


read 1260 times
9/1/2009 1:12:44 PM (last edit: 9/1/2009 1:13:02 PM)
show user profile  nm8r
Mashedpot8er: (not to diminish the importance of Interpolation)
Interpolation doesn't have any effect if the spline's segments are set to "Line" it only works with "Curve". Try it.
htt's problem usually happens when importing splines from CAD programs with .dwg or. dxf files and sometimes even Illustrator.
When the spline's segment is set to "Line" the vertices are somehow locked into corner mode.

I've never figured out why 3ds max only has the "Line" and "Curve" segment options on the Quad Menu and not on the Modify Panel's menu.
read 1253 times
9/1/2009 1:30:17 PM (last edit: 9/1/2009 1:48:58 PM)
show user profile  Mashedpot8er
It's weird, I tried what you said nm8r but when I do it your way it's still segmented. I tick the adaptive box and it turns smooth.

Does it do the same thing for you ?




Cad Monkey


read 1234 times
9/1/2009 7:02:48 PM (last edit: 9/1/2009 7:04:39 PM)
show user profile  nm8r
I'm not sure what's going on. I almost never use adaptive because I usually extrude splines and don't like the results from adaptive splines vs. those that are optimized.
read 1224 times
9/1/2009 9:24:17 PM (last edit: 9/1/2009 11:45:39 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org