Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(36 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

Skin modifier - quick question regarding envelopes
show user profile  avionz
Hi,

I've added a skin modifier to my model but for some reason some vertices can't be unselected by adjusting the envelopes.


The red vertices in the middle are part of the selected envelope (should be?) but even if the envelope is adjusted those vertices do not disappear. Any ideas?

I could use the physique modifier but that is not as flexible/easy to use as skin.

Thanks!
read 734 times
4/20/2008 7:34:34 AM (last edit: 4/21/2008 7:47:33 AM)
show user profile  ulisei
if you already used the weighttable and/or alter some values for single verts, max don't or can't reset that when you go back to envelope-mode.
but it's obviously to me on your screenshot, that these orange/blue vertices allready gets influences of the next bone, as it should be.

you can reset all values in the weight-table but i suggest to paint your values on with a brushsize about half the way between two verts and 50% strenght. easy and fun

greeetings, U.



read 710 times
4/20/2008 8:58:28 AM (last edit: 4/20/2008 8:58:28 AM)
show user profile  MrBurns
Try unchecking "weight all vertices"
read 705 times
4/20/2008 9:01:39 AM (last edit: 4/20/2008 9:01:39 AM)
show user profile  avionz
Thanks for the replies.

Ulisei, all I've done is scale the two 'circled' areas in each bone, I'm don't know what the technical term is, hehe :)

MrBurns, thanks I'll try that :)
read 698 times
4/20/2008 9:21:47 AM (last edit: 4/20/2008 9:21:47 AM)
show user profile  avionz
I think the "remove all vertices" has done the trick. But now, if I move the HISolvers the mesh does not react at all. Re-adding the bones makes no difference. Problem after problem :(

Thanks
read 692 times
4/20/2008 9:34:12 AM (last edit: 4/20/2008 9:34:12 AM)
show user profile  MrBurns
Have you tried selecting the unwanted vertices and clicking "exclude"?
read 689 times
4/20/2008 9:35:23 AM (last edit: 4/20/2008 9:35:23 AM)
show user profile  avionz
I just went back to a previous save and the mesh reacts with the bones now. The "weight all vertices" (sorry I put "remove all vertices" in my last post lol) has fixed it. MrBurns, I can't find 'exclude' option anywhere..maybe that's because I've disabled the above option :p

Anyway, its fixed now, thanks chaps :)
read 680 times
4/20/2008 9:45:38 AM (last edit: 4/20/2008 9:46:19 AM)
show user profile  MrBurns
You can include/exclude vertices and edit their weights if you check the "vertices" option right under the "edit envelopes" button.
read 664 times
4/20/2008 10:38:53 AM (last edit: 4/20/2008 10:38:53 AM)
show user profile  avionz
Ok, thanks for that, I'll remember it for next time :). Just one final question, how does one rotate the mesh and bones without deforming the mesh totally? I just want the whole model to face one way but it deforms so badly that it becomes unrecognisable :p

Thanks!
read 662 times
4/20/2008 10:46:47 AM (last edit: 4/20/2008 10:46:47 AM)
show user profile  MrBurns
I think it should work if you uncheck "always deform"
Make sure to check it again after adjusting your mesh/bones.
read 656 times
4/20/2008 11:01:10 AM (last edit: 4/20/2008 11:02:39 AM)
show user profile  avionz
Thanks MrBurns I will try that as soon I can.


The problem that I fixed earlier has started again. The mesh has totally stopped reacting to the bones. The bones are added in the skin modifier, and for now "always deform" is checked. It's all abit hit n' miss whether it wants to work or not. All my mesh faces/edges etc are unselected. I just don't know what to do. Can't believe my luck :(



read 650 times
4/20/2008 11:32:37 AM (last edit: 4/21/2008 7:47:22 AM)
show user profile  avionz
Is 'show end result' supposed to turned on for all modifiers/edit polys etc in the stack, for the skin to work properly? I did just this and the bones are working with the mesh again.

However, I'm not sure if this is a definite solution, or just a one off haha. Is there an Always deform option to rotate the bones around too? because the mesh rotates but the bones just mess up. Sorry about this.
read 640 times
4/20/2008 12:03:02 PM (last edit: 4/20/2008 12:03:24 PM)
show user profile  $$T-bone$$
for safety sake...always collapse your stack before adding skin. you don't need the turbosmooth until you've finished...it should be added on top of skin.(much easier to include/exclude a few verts than to mess with several)
you also have other bone influences (probly from the torso) that are affecting your hand there. like someone else said, use "include/exclude" to weed out these unwanted influences.
it's tedious, and painful, but it's the only way.
:)




read 616 times
4/20/2008 7:42:24 PM (last edit: 4/20/2008 7:43:29 PM)
show user profile  ulisei
i like t-bones way of thinking about getting problems out of the way by being accurate as you can be from start up. the oldskool but real safe (and, at least pro) way.

so what kind of object are you are rigging actually at all ?

the physique modifier also accept bones, btw.
and physique allows you to exclude all other bones from influencing, wich bones don't. give it a try!

hope this helps another bit.you will get it!


greetings, U.



read 608 times
4/20/2008 8:10:30 PM (last edit: 4/20/2008 8:10:30 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org