Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography



Maxunderground news unavailable

Rotation issue
show user profile  Seyren
Hello, a friend gave me an object of a project i'm working on, but turns out the object he gave me it's rotated, neither he or i know how this happened but we can't do this again and i would like to know if it's possible to fix this.

you can see the pivot is aligned with the world but the object is kind of rotated between 4 and 5 degrees, we tried rotating it untl it fitted but that didn't end in good results.

I want to know if there is a way to align the object to the world, i tried with the hierarchy options but i didn't manage to get it right

also i can't just align the vertex because the distance between them is very important (more than you think :P) and we need that exact distance between those models.

So please, if it's there any way to fix it i would really appreciate it ^^

Thanks in advance.

Seyren.
read 381 times
4/15/2014 8:30:01 PM (last edit: 4/15/2014 8:30:01 PM)
show user profile  Dave
I have no idea what I'm looking at, was being in perspective the best way to show this issue?

What is your friend using? Is he exporting objects for you, or giving you Max scenes?

"I flew over Egypt once"

read 378 times
4/15/2014 8:36:27 PM (last edit: 4/15/2014 8:36:27 PM)
show user profile  Seyren
He exported it as an obj, but turns out that he has it this way too in his scene, so somehow he did this long ago and he is not able to go back.

That was the top of the object, here is another view of the object.

read 372 times
4/15/2014 9:17:15 PM (last edit: 4/15/2014 9:17:15 PM)
show user profile  Dave
It's likely caused by some transform information that needs to get wiped. If there exists a scene where the object is correct, tell your friend to reset Xform on it before exporting.

Otherwise, I'm not really sure. I mean the problem is most definitely coming from the export itself, so if there's no original file to go back to, then you'll just have to re-create that piece. In the future though, ensure all transforms are reset before exporting meshes.

Oh... I'm assuming you've checked the rotation values, you say it's off by a few degrees so if the readout (F12) says the same, simply fix it there. (I assume this is not the case though)

"I flew over Egypt once"

read 343 times
4/16/2014 1:40:19 AM (last edit: 4/16/2014 1:40:19 AM)
show user profile  Seyren
Yeah, the problem is that that position is 0 rotation on all degrees, that's the real problem

We rotated it a little and more or less it's rotated like 4 degrees, more or less it gets straigt that way, we checked the coordinates of the vertexs and if we rotate it 4 degrees the difference between them in the Y coord is 0,100, that's the closest we managed to get.

I don't know if there is a maxscript out there that could solve this problem like checking the vertex and rotate until they are all the same in the Y coord for example, aside from that, i guess we'll gonna do it again.. :(

Thank you for the answer :)
read 335 times
4/16/2014 3:48:54 AM (last edit: 4/16/2014 3:48:54 AM)
#Maxforums IRC
Open chat window


Support Maxforums.org