Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography



Maxunderground news unavailable

3d max 5 rigging multiple characters using the same envelopes
show user profile  ceeejay
Im making players for a sports game and need to use different model for varing body shapes
and headwear and hairstyles etc.

I made and rigged the player but when I change it to an editable mesh I lose all the skinmodifier and the hours of work I did on enveleopes.

What I want to be able to do is use the same rig and envelopes for multiple characters that vary only slightly. At the moment I have to redo all the envelope for each individual which is impossible.

Can anybody help me get around this problem?

Im not using character studio. I just rigged the character and applied a skin modifier. It Animates fine, this is my only problem so far.
read 453 times
8/18/2009 9:55:40 PM (last edit: 8/18/2009 9:55:40 PM)
show user profile  Jollabollathan
Look up the Skin wrap modifier, it's made exactly for this. It even has a function to convert itself back to a Skin mod for exporting to game engines.

[EDIT] Oh wait, shit, you're using Max 5??!? That doesn't have skin wrap.

Well you could save out the envelopes from the Skin mod of a model to a file (down the bottom of the modifier panel), collapse the stack, edit the model into the shape of the new character, then add a new Skin mod and load the file and hope it works...but I'd be surprised if Max 5 can do that. Does it even HAVE Skin?

Get a newer version of Max. :P

read 433 times
8/19/2009 9:59:50 AM (last edit: 8/19/2009 11:44:24 AM)
show user profile  ceeejay
thanks for the reply.

Yeah, until now max five has always been more than enough.

Ill try doing what you said and hope for the best, otherwise Im gonna be spending some cash!


EDIT

max 5 does have skin.

Ok I tried it and it didnt work. All the options are there. I saved the evelopes then collapsed then re-applied the modifier and loaded in the envelopes but they were still reset to their original state.
I may be doing something wrong in the envelope load in screen as its a bit complicated, I wont give up just yet.

Until now I solved this problem by using the same model and making them different with texture, its alot simpler but dosent look good up close

Thanks for your help.
read 413 times
8/19/2009 8:32:41 PM (last edit: 8/19/2009 10:11:51 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org