Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(36 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

Rendering - Far too long!!
show user profile  stoot98
Hi Guys

I have created a scene in 3Dstudio max from models imported from ProENGINNER as .STL files. I have applied lighting to the scene (8 mr Area Omni lights representing LEDs, and 4 other lights) and some materials and have now come to render it. When i try to render it (a single frame) without shadows enabled the render takes under 30 seconds to render (at 800x600) but when i turn shadows on, for only the 4 main lights, not the LED lights) the render has taken over 8 hours to render on the same spec of machine (a Pentium D 3.4 with 2GB ram). This is my first time using 3dsmax for proper rendering and am not sure about whether this is normal, but it seems extremely excessive!

Scene Stats are:
- c. 200,000 faces
- 12 lights (4 main lights with shadows, 8 "LED" lights)
- 31 models

-using the default renderer

Does anyone have ideas if a) this is normal behaviour for such a scene? b) if i have done something stupid (i.e. set an option) that would cause this? or c) how i might speed things up?

Thanks in advance

Stuart

Ps. a render (without shadows) can be found here -

read 636 times
4/8/2008 10:38:19 AM (last edit: 4/8/2008 10:38:19 AM)
show user profile  Kajico
Don't use Mental Ray lights with the default renderer and vice versa. Use regular omni lights if you are using the scanline renderer, use mr omni if you are using mental ray.


(\/) (°,,,°) (\/) Woop woop woop!




read 634 times
4/8/2008 10:41:47 AM (last edit: 4/8/2008 10:42:37 AM)
show user profile  toldaddy
You need to run through some basic lighting tutorials. F1 and search lighting. mr area lights suck in default scanline renderer.. use mental ray if you're going to use mr area lights.

[edit] -doh.



read 626 times
4/8/2008 10:44:57 AM (last edit: 4/8/2008 10:46:01 AM)
show user profile  stoot98
wow, thanks for the fast response!

Right, ill have a go ditching those mr lights and see what likes it is.

Cheers
read 612 times
4/8/2008 10:55:23 AM (last edit: 4/8/2008 10:55:23 AM)
show user profile  stoot98
Right, Ive taken those lights away and kicked off a 320x240 rendering with the main omni light having shadows turned on. Its about half-way through after maybe 10 minutes so that looks slightly more promising.

Any other suggestions for why it might be taking so long?
read 602 times
4/8/2008 11:12:02 AM (last edit: 4/8/2008 11:12:02 AM)
show user profile  Jollabollathan
Nooo, you didn't need to get rid of the lights! Just change the renderer to Mental Ray.

And if the main omni lights have ray traced shadows on (as opposed to say area shadows) then you'll also need to use Mental Ray.

read 577 times
4/8/2008 11:37:54 AM (last edit: 4/8/2008 11:38:27 AM)
show user profile  stoot98
Hi guys

I changed the renderer to mental ray and it renders the scene in under a minute with full shadows! Thanks a lot, this has saved me many, many hours of rendering!!

read 540 times
4/8/2008 12:27:33 PM (last edit: 4/8/2008 12:27:33 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org