Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography



Maxunderground news unavailable

Rendering: Attached Object Disappears
show user profile  Kapoof
Hey all, i've got a skeletal mesh. I attach an object to any of the bones. Everything looks great in the viewport.

When i try to render it... the attached object is not showing up.

I've tried a number of render settings. Tried to attach an object to a variety of bones. Same result.

When i create two boxes quick, and attach them, they both do render however. =(

Is there any reason attaching a bone to an object would cause the object not to render?

Any help would be greatly appreciated.

Also, to be more specific, the model is from the game Gears of War. I'm trying to attach the gun (object) to the model (bone called weapon specifically made for gun attachments).

read 413 times
9/22/2011 9:04:45 AM (last edit: 9/22/2011 9:04:45 AM)
show user profile  Davious
might be an import issue with the model.
Have you tried attaching a dummy to the bone and an the gun to the dummy? might work
other than that I don't have much more of an idea sorry

" Difficult, yes. Impossible , no..."
read 409 times
9/22/2011 9:31:13 AM (last edit: 9/22/2011 9:31:13 AM)
show user profile  mrgrotey
Have the objects being attached been mirrored previously? max tends to flip the normals of mirrored objects when they are attached.




read 408 times
9/22/2011 9:31:34 AM (last edit: 9/22/2011 9:31:34 AM)
show user profile  Kapoof
Hey guys, thanks so much for the replies. I was able to link them rather than attach them, and that renders fine. I'll never know why attaching would cause the rendering problem, but it's alright because this works for me! :)
read 407 times
9/22/2011 10:54:08 AM (last edit: 9/22/2011 10:54:08 AM)
#Maxforums IRC
Open chat window


Support Maxforums.org