Forum Groups
  All forums
    Help & Feedback
      Work in progress
      Finished Art
      Non-Max related

Maxunderground news unavailable

Reflection map rendering oddities
show user profile  magarlick
Hi. I have a scene with a reflection map in it. With the map turned on the scenes takes ages to render. With it turned off, it renders much faster. So far no problem. But with the map turned on and set to 0, it still takes ages to render. Why is this, and can it be worked around? In other words, is there a way to speed up the rendering when the reflection map is set to 0?


Mark Garlick Words and Pictures Ltd
read 309 times
8/12/2016 4:47:26 PM (last edit: 8/12/2016 4:47:26 PM)
show user profile  mike_renouf
Can you explain what you mean by "set to 0". Which setting is this referring to?

read 303 times
8/12/2016 4:55:52 PM (last edit: 8/12/2016 4:55:52 PM)
show user profile  FX
Not having a clue which render engine your talking about...if it's set to "0" then it's leave it turned off...unless your referring to subdivs and not output.

read 300 times
8/12/2016 5:03:52 PM (last edit: 8/12/2016 5:03:52 PM)
show user profile  HANZZ
He's referring to the amount spinner in the main texture panel.

What renderer are you using? Are you using a reflection TEXTURE, or are you using Raytracing in the reflection slot? Huge difference.

 photo MorgothArisenSig_zpsup4yjp7o.jpg

read 274 times
8/13/2016 8:09:06 AM (last edit: 8/13/2016 8:09:06 AM)
show user profile  jpedleham
^Agreed, i despise raytrace in the reflection slot. It takes renders to a crawl.
read 253 times
8/13/2016 4:50:25 PM (last edit: 8/13/2016 4:50:25 PM)
show user profile  magarlick
Sorry for the delay, guys, and thanks for replying. HANZZ was right about the amount spinner.

Scanline renderer, using a falloff map in the reflection slot, with raytracer in one of the channels of the fallow. So jpedleham, this makes it slow, I know. But I can't understand why, when the amount is set to ZERO, it still takes an age. (I need to modulate the amount of reflection in the scene, so can't just turn off the map).

Never mind, I used a reflect/refract map instead of raytracer in the falloff map and it's way faster. Thanks.


Mark Garlick Words and Pictures Ltd
read 229 times
8/15/2016 12:48:21 PM (last edit: 8/15/2016 12:48:21 PM)
show user profile  HANZZ
the reason it still takes all that time even if it's set to zero, is because you're making it calculate it as though it is fully present, and then blending it together relative to a set amount of 0. Zero in this case doesn't translate to "ignore this totally", it translates to blend it onto the lower textures, but by zero amount.

 photo MorgothArisenSig_zpsup4yjp7o.jpg

read 215 times
8/15/2016 11:15:55 PM (last edit: 8/15/2016 11:15:55 PM)
#Maxforums IRC
Open chat window