Forum Groups
  All forums
    Help & Feedback
      Work in progress
      Finished Art
      Non-Max related

Maxunderground news unavailable

Quick exr / nuke question
show user profile  herfst1
I tested a rendered exr frame in nuke and couldn't find the render elements. Here are my settings:

I "enabled" all the elements (though it comes up with a message saying it'll work, they just look like they're turned off for memory's sake, or something like that). Also rendered with them turned off. No difference.

So it's either the way I saved it, or just nuke noobness going on.

With nuke I just checked the channels and none of the render elements were there. Don't think it's possible to open a file incorrectly, but I'll be happy to be proven wrong.

read 472 times
5/11/2015 4:52:31 PM (last edit: 5/11/2015 4:52:31 PM)
show user profile  BishBashRoss
Use the Vray framebuffer save options.

read 468 times
5/11/2015 4:54:10 PM (last edit: 5/11/2015 4:54:10 PM)
show user profile  herfst1
It's an animation sequence. I'll just check vfb right now.
read 465 times
5/11/2015 4:58:55 PM (last edit: 5/11/2015 4:58:55 PM)
show user profile  BishBashRoss
Animation is no problem. The Vray options will work fine.

read 463 times
5/11/2015 4:59:39 PM (last edit: 5/11/2015 4:59:39 PM)
show user profile  herfst1
Okay. I just checked my settings and this is what I had for vfb:

I saved that file and tried it in nuke and, again, no channels. So there must be some setting here that I've got wrong... I assume.

[edit] I'm thinking it's the "state" being off. I'll just check that right now.
read 458 times
5/11/2015 5:05:58 PM (last edit: 5/11/2015 5:07:10 PM)
show user profile  herfst1
Now I'm confused. I just saw I hadn't ticked "enable" for each and felt embarrassed. Then I saved it "correctly" and checked it and still nothing in nuke.

[edit] here's what I mean about nuke:

read 454 times
5/11/2015 5:09:05 PM (last edit: 5/11/2015 5:14:55 PM)
show user profile  BishBashRoss
Go to render settings. The look for Vray virtual frame buffer. Enable that and check the save options at the bottom. Save as EXR file.

read 452 times
5/11/2015 5:12:49 PM (last edit: 5/11/2015 5:12:49 PM)
show user profile  herfst1
I checked under render elements tab and VFB was enabled. It is also enabled in the Vray tab. I also already had the save options set to exr (it's in the first pic I posted). I really, really hope it's just a simple Nuke error, as I've already gone and rendered about 35 frames (at 33 minutes per frame). Just had a nagging feeling and needed to check nuke to see it worked. Should have done that after the first frame. :/

P.S. Thanks for your help so far BBR.
read 447 times
5/11/2015 5:21:19 PM (last edit: 5/11/2015 5:21:19 PM)
show user profile  BishBashRoss
I only ever use the Vray options "Render to raw image file". When you do it that way you don't save the files from the first tab like in your picture, it saves the layered EXR after each frame.

If your files are missing the render elements I think you'll have to re render them all sadly.

read 439 times
5/11/2015 5:37:36 PM (last edit: 5/11/2015 5:37:36 PM)
show user profile  herfst1
Damn. Thanks, I'll change to that option. I might get away with not re-rendering as I can do some fade from white or black for the opening seconds and grade to my composited version. Hell, it's only just over 1 second's worth.

Thanks for the help. Cheers.
read 430 times
5/11/2015 5:58:03 PM (last edit: 5/11/2015 5:58:03 PM)
show user profile  herfst1
Ah fuck. Checked. The channels do come up just fine, but the output is green. And not a good MF green, no, the shit kind of green.

read 428 times
5/11/2015 6:05:55 PM (last edit: 5/11/2015 6:05:55 PM)
show user profile  herfst1
I've just gone through this thread and followed all the advice. But it's still not working.

Only final clue is this message. Afterwards the "enabled" is unticked.

read 414 times
5/11/2015 7:13:10 PM (last edit: 5/11/2015 7:13:10 PM)
show user profile  BishBashRoss
Ignore that message.

It is very simple to get working (although perhaps not entirely intuitive).

So start from scratch and follow these instructions.

1) Do not use the save dialogue in the common tab of the render setup.

2) enable Vray virtual frame buffer from the render settings.

3) Below the 'enable built in frame buffer' check box there is another 'Render to Vray Raw image file'. Check that and use the save dialogue below to save as an EXR file.

4) add render passes from the render elements tab. Doesn't matter if enabled or not.

5) Hit render. If you are saving a file sequence you may see a warning. Ignore it.

read 409 times
5/11/2015 7:28:01 PM (last edit: 5/11/2015 7:39:50 PM)
show user profile  herfst1
Ah, beautiful. Just went through it one, by one and it worked. You're a champ. Thanks, ross.
read 404 times
5/11/2015 7:37:58 PM (last edit: 5/11/2015 7:37:58 PM)
show user profile  BishBashRoss
No probs.

read 399 times
5/11/2015 7:43:35 PM (last edit: 5/11/2015 7:43:35 PM)
#Maxforums IRC
Open chat window