Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(37 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

 
First page  Go to the previous page   [01]  [02]  Go to the next page  Last page
 
Problems removing texture seams
show user profile  ceeejay
Im trying to learn to remove seams as it is really holding back my visuals. I have not succeeded
yet and have run into several problems but this one is stopping me at the moment.

Im trying to remove the seams under the arms, and when I render to texture the polygons or
detail on one side of the seam is not rendering.

Using the exact same method on the other side of the model works fine oddly enough...any
ideas on what I have done wrong to cause this?

BTW Im trying to follow this tutorial
http://www.gamasutra.com/view/feature/1800/completely_eliminate_texture_seams_.php


Heres a pic of the problem.


read 1642 times
6/13/2011 3:05:02 PM (last edit: 6/13/2011 3:05:49 PM)
show user profile  Garp
Look at grotey's excellent turtlerial in the featured threads on the left.
The last part is dedicated to seam removal.




read 1635 times
6/13/2011 3:09:52 PM (last edit: 6/13/2011 3:09:52 PM)
show user profile  ceeejay
Thanks for the reply,

That was my first stop, but i cant view any of Mr Groteys tutorials. It just says page cannot
be displayed. I can view the website fine.

However, I think this problem may be with my mesh rather than my lack of understanding of
seam removal (although my lack of inderstanding is significant!) as one side of the model renders to texture nicely but othe other does not.

This result is consistent no matter how many do-overs I try.
read 1631 times
6/13/2011 3:17:53 PM (last edit: 6/13/2011 3:17:53 PM)
show user profile  ceeejay
I was just watching that high to low poly knife tut that liondebt posted in another thread and
he said something that might be exactly what my problem is.

When I mirrored my mesh and welded t together, I did not reset xform. Is this why the left side
only is giving me problems?
read 1611 times
6/14/2011 12:59:17 AM (last edit: 6/14/2011 12:59:17 AM)
show user profile  Garp
I think there's a misunderstanding:
- what you say : small image -> no seam, large image -> seam
- whay I see: small image -> seam, large image -> mapping error




read 1603 times
6/14/2011 2:03:31 AM (last edit: 6/14/2011 2:03:31 AM)
show user profile  ceeejay
Sorry for my part in any misunderstanding.

I have not painted out the seams yet, I didnt get that far. These are just the intial renders to texture that I will paint over in photoshop.

The small image is what it should look like and does on the right side of my model.(ready to import
to photoshop and paint over) The large image is what happens when I follow the same steps but on the left side of the model.

I agree that its a mesh error, but have no idea what it is. Its uvw mapped and the texture displays fine. Its when I started rendering to texture to remove seams that this happened.
read 1593 times
6/14/2011 2:53:25 AM (last edit: 6/14/2011 3:29:36 AM)
show user profile  ceeejay
I thought I fixed the problem.

I deleted half of the mesh the re-mirrored it, reset x-form, flipped normals and welded it
together and it worked!

My joy turned to dismay as the problem has now simply shifted to the right side of my model. Same
problem as the pic above just on the opposite side.

Im getting really frustrated, I feel like Im making a simple mistake but I just dont know what it is.


read 1571 times
6/14/2011 12:25:57 PM (last edit: 6/14/2011 12:25:57 PM)
show user profile  mrgrotey
not sure why you cant get my tutorial vids, I can download them fine, anyone else having trouble?

Grotey

read 1566 times
6/14/2011 12:36:40 PM (last edit: 6/14/2011 12:36:40 PM)
show user profile  ceeejay
When I click on them here or on your website I just get told that the page cannot be
displayed.

Any idea what I might have done to kill my mesh?

A little more info about what Ive done here might help,

The mesh I built is a sports player, originally it had 3 textures, one for the limbs one for the
head and they were all sharing the same map channel (didnt know anything about map channels)
Anyway, at the final stage of the seam removal, the final render to texture it rendered all 3
textures on top of each other and I realised I had to start again.

Next, I deleted the head and limbs, leaving the uniform with one texture in map channel 1 so
I could have a clear run at seam removal.

It was at this point that I ran into the problem I posted in the pic above. This was not happening
on the original full mesh.




read 1562 times
6/14/2011 12:49:45 PM (last edit: 6/14/2011 12:49:45 PM)
show user profile  Garp
Just a wild guess, could it be a material ID not assigned correctly?

@Mike: download is fine for me.




read 1558 times
6/14/2011 1:56:58 PM (last edit: 6/14/2011 1:56:58 PM)
show user profile  Sangre
Are you using UVW Mapping modifier? If so, you should definitely use Unwrap UVW. Your model has a way too complex shape for simple UVW Mapping. Learning how to use Unwrap UVW is hard but crucial in texturing.
read 1545 times
6/14/2011 2:33:27 PM (last edit: 6/14/2011 2:33:27 PM)
show user profile  mrgrotey
I've never understood why that gamasutra tut suggests using 3 or 4 unwrap modifiers, completely pointless if you ask me. I only use one, and that's a temporary one at that. Have you tried right-clicking and saving the vid on my tutorial rather than left clicking it?

Sangre: the uvwmap modifier is perfectly fine for localising the seam area, assigning it to a different ID them baking out the texture paint over. its not used for the main unwrap, its just a temporary stage to fix the texture.

Grotey

read 1540 times
6/14/2011 2:45:37 PM (last edit: 6/14/2011 2:47:39 PM)
show user profile  ceeejay
Thanks guys.

I tried just doing the same thing on a basic cylinder, and I didnt have the same problem. Definately
my model, quite possibly mat IDs. I think Im just going to start the model again. It was a bit
messy anyway.

I was able to get to the last stage of the gamasutra tutorial before I failed(using a cylinder) I painted over the seams and applied it to the mesh in map channel 2 and it looks fine, however applying the new material to the model removed the orignal material so on the final render to texture to get the whole thing together the information from the orignal material is gone and does not render. Just my nice new seam and all the rest has no mapping.

I right clicked and saved your tutorial and am downloading it now. Ill go through it and see if
I cant remove a damn seam for the first time.

Ill report back tomorrow sometime with any progress.

Thanks a bunch.
read 1527 times
6/14/2011 3:09:25 PM (last edit: 6/14/2011 3:09:25 PM)
show user profile  ceeejay
Well, I removed my first texture seam.......kind of. I removed most of it but somehow managed
to create another small seam during the process. I think this was mainly due to me rushing
through this morning before work. I will have another go tonight and do it properly.

Its a great vid, I now understand how seam removal works and after many hours of confusion
on the gamasutra tut I actually found it quite straight forward and it didnt take
very long at all.

Im just so happy to have made some positive ground on this, I was getting so frustrated.

Thanks heaps.

read 1512 times
6/15/2011 1:40:00 AM (last edit: 6/15/2011 1:40:00 AM)
show user profile  ceeejay
Check it out! Seam removed!!

Im destroying seams left and right, I cannot be stopped! Thanks again!!!!!

read 1496 times
6/15/2011 1:18:57 PM (last edit: 6/15/2011 1:18:57 PM)
 
First page  Go to the previous page   [01]  [02]  Go to the next page  Last page
 
#Maxforums IRC
Open chat window


Support Maxforums.org