Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(36 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

Problem with asphalt texture
show user profile  Mithrandir
I'm pretty new to 3D studio Max. I'm trying to apply asphalt texture using ProMaterials Generic in 3ds max 2009.

I've created an asphalt texture in photoshop. Here is the link:

I've created a new 3D scene, created a box, applied ProMaterials Generic with diffuse map of my asphalt texture to the box, added a Daylight system.
Problem is, that in the viewport, texture looks just the way I want, but when I render it (renderer is mental ray), texture on the box appears gray instead of black.
I can't figure out what I'm doing wrong.

Here is the link to 3ds max file: http://marvin.kset.org/~mtosic/road_test.max

read 3851 times
3/24/2009 5:45:55 AM (last edit: 3/24/2009 5:45:55 AM)
show user profile  Westcoast13
Probably exposure control killing the contrast.


My Turbosquid Area

read 3832 times
3/24/2009 6:13:42 AM (last edit: 3/24/2009 6:13:42 AM)
show user profile  Mithrandir
I've posted here just an apshalt texture applied on box. I'm adding materials to the model of shopping mall. All other materials look pretty fine. I'm having problem just with asphalt texture.
read 3828 times
3/24/2009 6:15:39 AM (last edit: 3/24/2009 6:15:39 AM)
show user profile  mrgrotey





read 3823 times
3/24/2009 6:18:38 AM (last edit: 3/24/2009 6:18:38 AM)
show user profile  zeefusion
black does come up grey most of the time, you will need to tweak your lighting and exposure settings. Like Westcoast said.
read 3822 times
3/24/2009 6:18:59 AM (last edit: 3/24/2009 6:18:59 AM)
show user profile  Mithrandir
I'm sorry for not posting pictures. Ive played a bit with exposure control.I cannot set it larger than 16, but on 16 it looks too dark and unnatural, on 15 it's better (which was default). Here is how it looks right now:
Viewport:

Render with EV15

Render with EV16

Don't look at textures, I'm still playing with materials :))
read 3806 times
3/24/2009 7:10:39 AM (last edit: 3/24/2009 7:31:27 AM)
show user profile  Chris123643
i opened the file you gave, but i couldn't see the texture (because its saved on your computer) also it looked nothing like your images, it was just a box. anyway.. its difficult to see what the problem is. use the UVW modifier, also make sure the 'show standard map in viewport' button (white and blue cube in material editor) is selected on the correct part of your material... if you have a bump map for example, and had that button selected while in the bump section, what you are seeing is the bump texture, not the material texture itself.


read 3783 times
3/24/2009 7:55:13 AM (last edit: 3/24/2009 8:00:26 AM)
show user profile  Mithrandir
In the first post, the first image is texture what I'm using to wrap it around the box, so you can save it and apply it to the box.
Model of the shopping mall is 180MB big, so I've created just a box and a daylight system to make the file smaller and applied the texture to it.
In my shopping mall model, UVW modifier is applied. I don't have a bump map, just a diffuse map.
I think that UVW mapping is not needed on standard primitives.

Here is box in viewport:

Here is the render:

read 3773 times
3/24/2009 8:28:23 AM (last edit: 3/24/2009 8:28:23 AM)
show user profile  Dejitarujin
That really doesn't look like the texture is applied in the renderer at all. Are you sure the mapping coordinates are right? I've had numerous problems where the texture appears perfect in the viewport, but not at all in a render (usually due to scale issues).
~~~
Specialty: Non-organic modelling and effects.
Setup: 3D Studio 2010 with finalRender.
Rig: No, no I can't.
read 3753 times
3/24/2009 10:50:06 AM (last edit: 3/24/2009 10:50:06 AM)
show user profile  Mithrandir
In the first post, there is texture(applied as the diffuse map) and link to .max file, so you can try it if u want. I've played with UVW Map and scaling, but without success. I think that the map is applied, because no matter what diffuse color I choose, the result is always the same.
read 3708 times
3/25/2009 5:54:26 AM (last edit: 3/25/2009 5:54:26 AM)
show user profile  mrgrotey
I'll have a look at the max file tonight (I forgot to last night) but is the diffuse slot set at 100 in the list? Also is the diffuse channel ticked? (I presuming yes as you say the diffuse color swatch changes nothing.

Have you tried changing the asphalt texture to something completely different, like a really colourful image as a test to see if the colour on the render changes. If it doesnt change then the bitmap is not being applied somehow. If it does change then its may well be the scale of the uvs or the bitmap. (probably not the uvs as the primitive box will have correct uvs. so are the tiling values of the bitmap set to 1.0?

just throwing some ideas out there, no sure any will fix it.




read 3702 times
3/25/2009 6:00:24 AM (last edit: 3/25/2009 6:01:15 AM)
show user profile  Westcoast13
Apply a uvw map to the box (in your scene), uncheck Real world map size and type in some dimensions for your asphalt map.

Worked on mine then......


My Turbosquid Area

read 3697 times
3/25/2009 6:13:31 AM (last edit: 3/25/2009 6:13:31 AM)
show user profile  Chris123643
yep... worked on mine then too... you need to apply the UVW map.


read 3684 times
3/25/2009 6:59:17 AM (last edit: 3/25/2009 6:59:17 AM)
show user profile  Mithrandir
Thank you, I've tried UVW Map before, and turning real time scaling off...but obviously I was setting tiling too high. Now I can see details on the texture, but it's still too bright (it's gray).

I'm noob in texturing and materials (in 3ds max also:)) and I don't know how to make my asphalt darker. I'm really sorry for annoying you all :)
Here is how it looks now after render:

Also, I've updated max file (UVW map modifier is added and tiling set to 2).
Here is the link: http://marvin.kset.org/~mtosic/road_test.max

read 3679 times
3/25/2009 7:20:01 AM (last edit: 3/25/2009 7:20:30 AM)
#Maxforums IRC
Open chat window


Support Maxforums.org