Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(37 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

Play animation skipping frames
show user profile  Nolan
Hello all,

I am working on an animation and when I click the play animation button (not render) it seems to be skipping frames or have a very low frame rate. It works fine in other files and doesnt seem to be the computer but it is very annoying when trying to view the animation. I checked the time configuration settings and every thing seems to be good. Its running at 1/2 speed and 30 fps. Thanks in advance for any advice.

Nolan
read 782 times
6/20/2011 4:02:55 PM (last edit: 6/20/2011 4:02:55 PM)
show user profile  Nik Clark
Turn off realtime?



read 780 times
6/20/2011 4:07:12 PM (last edit: 6/20/2011 4:07:12 PM)
show user profile  Nolan
That seemed to make it stop skipping frames but now it is ignoring the fact that i set it to play at 30 fps. Its playing somewhere from 5-10 fps.
read 773 times
6/20/2011 4:34:02 PM (last edit: 6/20/2011 4:34:02 PM)
show user profile  Nolan
Also I just noticed about the last 20 frames of my animation it goes back to being smooth... If that helps at all. Im still stumped.
read 765 times
6/20/2011 4:39:42 PM (last edit: 6/20/2011 4:39:42 PM)
show user profile  Kajico
Animation>>Make Preview

or if it's newer version of max

Tools>>Grab Viewport>>Make Animation Sequence.

It will buffer render an animation from your viewport into a video file so it's viewable at the accurate speed. Your viewport speed will vary depending on your card, drivers and scene complexity, it's always best to make a preview.


(\/) (°,,,°) (\/) Woop woop woop!




read 764 times
6/20/2011 4:42:22 PM (last edit: 6/20/2011 4:42:22 PM)
show user profile  Nolan
Hmm I did that and it made the sequence but it didnt seem to change anything.
read 758 times
6/20/2011 5:04:26 PM (last edit: 6/20/2011 5:04:26 PM)
show user profile  Nik Clark
Your computer is doing these things because it can't keep up with teh requested speed. So, it has to either skip frames or play at a lower speed.

Your two options are to allow adaptive degradation, or to make a preview, as Kajico said.

Making a preview creates an avi, so gives you a movie to watch, rather than in the max viewports.



read 752 times
6/20/2011 5:12:45 PM (last edit: 6/20/2011 5:14:20 PM)
show user profile  Philbert
You could also:

> use a faster computer

> Hide parts of the scene you don't need to see (splitting things between layers is good for this)

> Turn off meshsmooth on objects

> Put an optimize modifier on your heavy mesh to cut down the polys

Basically your current set-up can't push that many polygons fast enough so you gotta change that


 Everybody`s Got Something To Hide Except Me And My Monkey

read 738 times
6/20/2011 6:37:42 PM (last edit: 6/20/2011 6:37:42 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org