Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(37 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

PFlow go to rotation?
show user profile  KingRoLo05
Hi, could anyone with pflow experience please shed any light on this problem I'm having?

I've basically created a flat grid of circle shapes which spin randomly along one axis like a sheet of glittering sequins slowly rotating.

My problem is that I'm trying to get the animation to loop at the end so i used a spin op to get the shapes to rotate with a slight variation on the spin, a rotation op with some divergence for randomness at the beginning and used a Go To Rotation to get the shapes to return to their original starting point at the end.

However it appears that when I use variation on the Spin Op it causes the shapes to glitch and act strange during their rotation which I think has something to do with the Go To Rotation.

It's as if all shapes are trying to arrive at their final rotation but the Go To Rotation is having problems achieving this smoothly because of the variance on the spin. If I put the variation to 0 it's fine but the animation looks flat and repetitive without the variation.

Is there any way around this?

Thanks.


read 318 times
4/15/2015 11:23:40 PM (last edit: 4/15/2015 11:23:40 PM)
show user profile  digs
could just be the viewport having trouble updating? might look ok in a playblast / render
read 314 times
4/16/2015 4:40:58 AM (last edit: 4/16/2015 4:40:58 AM)
show user profile  KingRoLo05
I tried a render and the rotation glitches as per the viewport. Did a quick search and tried the autodesk example here:
http://knowledge.autodesk.com/support/3ds-max/learn-explore/caas/CloudHelp/cloudhelp/2015/ENU/3DSMax/files/GUID-55BDDA3A-3F75-42B6-9A3F-4BAC2FC9C0F2-htm.html

And it works however when i start adjusting the axis rotation on the Rotation Op to suit my own project it starts to glitch again. Weird, there's also a paragraph with warning signs masking it out that says Warning: The Go To Rotation test is not compatible with the Spin, Shape Facing, and Shape Mark operators. Do not use any of these operators in the same event with a Go To Rotation test.

Thanks anyway.
read 290 times
4/16/2015 6:02:33 PM (last edit: 4/16/2015 6:02:33 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org