Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(36 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

Multi-subobject textures not working (wont appear on model/unable to assign)
show user profile  ShurikenUK
Recently I've been trying to get to grips with multi-sub textures, so I can make more intricately textured models, like the buildings I've been working on, which are too big for just one UV map. I've watched some youtube tutorials and looked around, but I cant seem to get this kind of texture to work on any of my models.

I've tried modelling a pillar with glass-pane lights in each face. I wanted to add the glass pane parts to an emissive texture, so they glowed without the need for extra lights. What I did is create the model, select all the glass pane faces, then press "set ID: 1" in "Polygon > Material ID's". Next, I selected everything else, then set them all as ID:2. I then created a new multi-sub texture in the material editor. I set the number of materials to 2, since thats all I need. Next, I assigned a texture to each of the two slots, gave them a name, then dragged the texture onto my model, finally pressing the button that makes your chosen material appear on your model. However, nothing happened at all.

Does anybody know what could be causing this? I can get normal "single part textures" to work, so I'm sure I must just be overlooking something ridiculously obvious...

Hope some1 can help me out! Thanks!

Edit: Okay I dont know WHAT I did, but I just managed to get "material ID:1" to appear on my model, but still no ID:2.
read 396 times
11/13/2011 7:56:32 PM (last edit: 11/13/2011 8:07:07 PM)
show user profile  moid1111
are you using max 2009?
i dont know how to solve it
i have the same problem
read 388 times
11/13/2011 9:28:57 PM (last edit: 11/13/2011 9:28:57 PM)
show user profile  Davious
is it not appearing in the viewport or the render ?
I seem to remember with multi-sub, the "show material in viewport" button must be selected in the sub-material level. Not the top level of the material.

Other than that , start with a simple object. Assign the material ID, then de-select it, then go back to it and use the select ID to make sure you have the materials assigned correctly. Then try a multi-sub assigned to it.

Other than that I'm stuck

" Difficult, yes. Impossible , no..."
read 385 times
11/13/2011 9:35:05 PM (last edit: 11/13/2011 9:35:05 PM)
show user profile  moid1111
here is other solution for the problem
create multiple material slots, and each material give her different ID in M ID botums down the slot
as you did , give some of the poly ID 1 and others the ID 2
then drop both materials in the pillar every thing will be ok then

i hope its clear

read 380 times
11/13/2011 10:24:47 PM (last edit: 11/13/2011 10:24:47 PM)
show user profile  K-tonne
drag and drop is your problem
got the object level- ie. with no sub-object (polygon, vert, etc) level selected but the object still is selected and use the 'put material to selection' button in the material editor
drag and drop with a polygon selected will apply the material currently selected (even if it's a multmat number) to that polygon- or all the polygons with that id

Website and Portfolio

read 374 times
11/13/2011 10:57:24 PM (last edit: 11/13/2011 10:57:24 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org