Forum Groups
  All forums
    Help & Feedback
      Work in progress
      Finished Art
      Non-Max related

Maxunderground news unavailable

First page  Go to the previous page   [01]  [02]  Go to the next page  Last page
Model from Mudbox to 3ds Max has bad smoothing (not smoothing groups)
show user profile  atf10sko
I searched the forums, but couldn't find anyone with a similar problem (not sure what keywords to use, and might have used the wrong ones).

The model looks fine before rendering, but the weird faceting appears in the render image. I've tried exporting the level zero and level one mesh with the applied normals, and I get the same problem with faceting.

I've done the modelling with the following workflow:
Firstly I imported the standard human body mesh from Mudbox into 3ds Max to edit it roughly.
I then exported that model to Mudbox to do some detailed modelling followed by some painting.
After that I imported the model back to 3ds Max to rig it, but the model looked like in this picture:

I tried working with smoothing groups, which worked great before, but it doesn't seem to have any impact.

I'm new to 3D modelling so it might be a simple mistake, but I can't seem to find any help when I search for it.

Thanks in advance!
read 754 times
3/25/2015 9:18:57 AM (last edit: 3/25/2015 9:22:00 AM)
show user profile  herfst1

Maybe also the normals are getting screwed. Add an edit normals modifier, choose vertex, select all, then press reset.

[edit] also, potentially, the faces are inverted. Select all then press flip.
read 746 times
3/25/2015 9:33:48 AM (last edit: 3/25/2015 9:34:53 AM)
show user profile  atf10sko
Thank you for the fast answer!

I tried resetting the normals the way you said, but it didn't change the result. I also tried the unify command, which didn't help either.

The faces seem to be facing the right way, when I flipped them the wrong side got rendered (I could see through the chest and the inside of the back was rendered).

How should I use welding? The vertices seem to be connected to the main body, since moving one dragged the polygon out. I tried selecting all vertices and then pressed weld, since that previously helped me when I had used the mirror modifier (which I haven't used since the export to mudbox).

edit: I just tried sending the mesh over without the normal map on it that I generated in Mudbox which transfers the detail from the higher levels, and it seems to be working. I therefore think that the problem lies with Mudbox and how I create these normals, so I'll look into that.

Any other suggestions are welcomed in the meantime :)
read 739 times
3/25/2015 9:51:49 AM (last edit: 3/25/2015 9:56:43 AM)
show user profile  herfst1
Go to border subobject mode (press 3) and press ctrl+a. If red lines appear anywhere on your model that means you have unwelded verts. Press crtl+1 and press weld.
read 731 times
3/25/2015 10:46:47 AM (last edit: 3/25/2015 10:46:47 AM)
show user profile  atf10sko
Just tried that and I didn't find any red lines, so the model seems to be welded :)
read 729 times
3/25/2015 10:50:35 AM (last edit: 3/25/2015 10:50:35 AM)
show user profile  herfst1
Okay, then I'm out of ideas (except smoothing groups, which you said you already fixed).

Just in case you did it incorrectly:
Press 4, press ctrl+a, then go to smoothing groups tab, press reset, then click 1.
read 728 times
3/25/2015 11:00:59 AM (last edit: 3/25/2015 11:00:59 AM)
show user profile  atf10sko
Tried resetting it again the way you said, still nothing :(
I'm becoming more and more sure that the problem lies with Mudbox and the generated normals that transfer the details between the levels.

Thanks for all your tips!
read 718 times
3/25/2015 1:26:20 PM (last edit: 3/25/2015 1:26:20 PM)
show user profile  Dave
Make a box.
Align it to the pivot of your mesh.
Convert the box to edit mesh.
Attach the problem mesh to the box.
Delete the box (sub-object faces or element selection)

"I flew over Egypt once"

read 714 times
3/25/2015 2:46:15 PM (last edit: 3/25/2015 2:46:15 PM)
show user profile  atf10sko
Hi Dave,
I tried doing what you described but it didn't affect the issue :(

I'm getting more and more sure that I have to solve this in Mudbox by creating better normal-maps and that 3ds Max is showing everything correctly.
read 700 times
3/26/2015 8:52:01 AM (last edit: 3/26/2015 8:52:01 AM)
show user profile  herfst1
You had normals on? I should have read your whole message.

Use xnormal to render normals easily (and it's free). Just make sure your low poly version is all one smoothing group and that both meshes are in the exact same position then export both of them as obj's.
read 698 times
3/26/2015 9:11:12 AM (last edit: 3/26/2015 9:11:12 AM)
show user profile  Mr_Stabby
mudbox is real touchy when it comes to UV's, my guess its something to do with that. Regardless, adding a subdivision layer should fix it

read 696 times
3/26/2015 10:16:13 AM (last edit: 3/26/2015 10:16:13 AM)
show user profile  atf10sko
I'll try that herfst1!

Mr_Stabby, I have five subdivision levels already, should I add another one? I unwrapped the UVs in 3ds Max and flattened it before I exported it to Mudbox. The UVs look like this:

read 693 times
3/26/2015 10:46:03 AM (last edit: 3/26/2015 10:46:03 AM)
show user profile  Mr_Stabby
>> I have five subdivision levels already, should I add another one?

oh.. no. I misred the original post. Have you tried applying the "Normal" modifier in max with unify checked and flip unchecked?

read 690 times
3/26/2015 10:58:44 AM (last edit: 3/26/2015 10:58:44 AM)
show user profile  atf10sko
I tried applying the normal modifier with unify checked and flip unchecked, it didn't change much :(

I hade some success when I used xnormal instead, thanks a lot for the tip herfst1! It looks much better now.
I just used the standard settings in xnormal and it looked good, except around some edges around the shoes and the hands looked a bit weird (they are the priority).
I've added a screenshot on how the hands render, do you have any thoughts on how to improve them?

edit: Added the normalmap as well

Thanks again for all the help!
read 665 times
3/27/2015 2:38:25 PM (last edit: 3/27/2015 2:40:31 PM)
show user profile  digs
I didn't see this mentioned - but you may need to override gamma of the normal map - open your material editor, dbl click the bitmap node, open the normal map file location, select the normal map you want to apply, and enable Gamma "Override" -> 1.0

also, if you baked the normal map with positive x,y, and z channels in xNormal, you need to flip y in max - double click the normal bump node, flip green channel

that, and cleaner uv's always help
read 651 times
3/28/2015 1:05:54 AM (last edit: 3/28/2015 1:09:43 AM)
First page  Go to the previous page   [01]  [02]  Go to the next page  Last page
#Maxforums IRC
Open chat window