Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography



Maxunderground news unavailable

Mental Ray Rendering Error
show user profile  npcph
So i've been working with Mental Ray trying to figure out the setting and get something that looks somewhat decent. So i turn on max yesterday and when i hit render, it gives an error

Mental Ray Fatal Error
Mental Ray has encountered a fatal error and the application will now shut down. The error is:
MEM 0.3 fatal 031008: can't allocate 111471044 bytes.

So i restarted the computer and made sure nothing else was running and it still does it. I made a single box in a new scene and rendered it and same thing. So i shut down everything that is running in the background and it still happenes. I unplug everything and reseat the memmory. still the same. doesn't do it with scan line, just mental ray. I watched the processors and memory useage and there isn't even a spike on anything when i hit render. it just crashes. I've even tried turning off the 3 gig switch and turning it back on. same thing. i made sure i was virus free and windows is up to date. I also checked and windows is seeing the full 8 gig of ram.

my specs are
Max 2011 with all hot fixes and service packs
Dell m6500 laptop.
i5-540 processor 2.53 GHz
8 gig of ram
Nvidia Quadro FX 2800m with 1 gig dedicated.

My first guess would be faulty ram chips, but not sure since everything is showwing them properly. any thoughts on what might be the problem, i would appreciate it.

read 1702 times
12/30/2011 2:21:02 PM (last edit: 12/30/2011 2:21:02 PM)
show user profile  Nik Clark
3 gig switch with windows 64bit?

If you think you have faulty ram try this:http://www.memtest.org/

But, it sounds like some setting you have used is making MR bomb out immediately. Is anything set to stupidly high numbers in the render settings, etc?



read 1687 times
12/30/2011 6:14:13 PM (last edit: 12/30/2011 6:14:13 PM)
show user profile  npcph
I'm on windows 7 pro 32 bit. i was thinking about something being to high in the render settings, but it is even when i just start a new scene and just a box without anything even materials or lighting. even at the highest level it should at least render. I had a pretty complex scene and it rendered fine with pretty high settings. I watched the ram and processors while it rendered and neither did anything different. almost like they weren't even effected at all.

I went into my bios and it shows 8 gig installed. then i saw the post by horizon about it only showing 3.5 gig of his 4 gig of ram in windows system. So I checked mine and it has 8 gig and only shows 3.5 available. I did everything that was suggested and no effect. Mine already had maximum memory unchecked. so i checked it and rebooted. same thing. then i switched it back and still the same.

I'll try the mem test that you suggested though. thanks
Phil

read 1678 times
12/30/2011 10:51:07 PM (last edit: 12/30/2011 10:51:07 PM)
show user profile  Nik Clark
I presume you know that 32bit Windows will never use more than about 3.6 GB of ram (per app)?

Good luck! Without knowing more about the scene, I don't know why it's failing to allocate the ram. What it's asking for doesn't seem that much. I am still leaning towards it's some setting turned up too high in the mr scene.



read 1676 times
12/30/2011 10:55:29 PM (last edit: 12/30/2011 11:01:09 PM)
show user profile  Bolteon
got your fix...



stop using this horrible software.


sorry, i'm currently not enjoying the vestiges of mr. by force.

-Marko Mandaric



read 1668 times
12/30/2011 11:05:28 PM (last edit: 12/30/2011 11:05:28 PM)
show user profile  Nik Clark
I won't argue with Bolte's comments. MR can be, um, challenging at times. However, switching from 32bit to 64bit will get round a lot of memory problems. Max on 32bit sucks quite a bit.



read 1664 times
12/30/2011 11:11:56 PM (last edit: 12/30/2011 11:11:56 PM)
show user profile  npcph
I did not know that about 32 bit windows, but wouldn't windows show more then 3.5 available? And i also notice in task manager that it shows at that bottom total physical memory is 3572. even though windows 7 only able to use 3.5 megs per app, shouldn't it still show 8192 since that is what is in the system, or if it only will show the 4 gig (4096)

and i only saw that when i saw horizons post about his only showing 3.5 gig available and wondered if that was the problem.

i would love to switch to vray but not in my budget.

read 1657 times
12/31/2011 5:12:40 AM (last edit: 12/31/2011 5:12:40 AM)
show user profile  npcph
Well, i figured out why it kept crashing. I never made this change, so not sure how it happened.... and i feel a little foolish not having seen this earlier. Under final gather, i had rays per FG point set at 10000000. Not sure how this got changed (or if i did it by accident), but dropping that to 1 fixed the problem.

read 1636 times
1/2/2012 5:12:55 PM (last edit: 1/2/2012 5:12:55 PM)
show user profile  Nik Clark
Lol, so I was right! Glad you figured it out.



read 1629 times
1/2/2012 7:37:53 PM (last edit: 1/2/2012 7:37:53 PM)
show user profile  npcph
It was very frustrating. I don't remember changing that. and i only noticed it by chance. i was minutes away from trying a reinstall.

read 1624 times
1/2/2012 7:49:25 PM (last edit: 1/2/2012 7:49:25 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org