Forum Groups
  All forums
    Help & Feedback
      Work in progress
      Finished Art
      Non-Max related

Maxunderground news unavailable

Max memory error with JPGs
show user profile  magarlick
Hi folks

This is a curious one. I am using Max on a laptop: Windows 7 x86, 4Gb RAM. I create a new scene. With NO GEOMETRY in it, I open Material Editor and try to assign a bitmap to the Diffuse channel. I have noticed that if the bitmap is a JPG bigger than about 5000 pixels wide, I get a box pop up with the title "Image I/O error". It says Memory Error. As I said, only with larger pixel JPGs. I tried saving the JPGS with greater and greater compression, but it made no difference. Only the pixel size counts. I just assumed the PC can't cope, although I am sure it used to work with JPGS of this size.

Then, strangely, I tried assigning a PSD and a layered TIFF file instead, which have the same number of pixels but are much larger obviously in terms of file size. This time there is no problem.

I am totally at a loss. I don't want to use TIF and PSD because the files are huge. Why can't I get this to work with JPGS anymore?

Bitmap paging makes no difference. PC is not doing anything else intensive.

Thanks a lot.


Mark Garlick Words and Pictures Ltd
read 1728 times
12/23/2011 10:35:52 PM (last edit: 12/23/2011 10:35:52 PM)
show user profile  Sir_Manfred
*waits for AS to post something about jpeg2000*

Visit my Portfolio

read 1724 times
12/23/2011 10:48:37 PM (last edit: 12/23/2011 10:48:37 PM)
show user profile  ScotlandDave
I had a similar problem recently trying to save massive jpegs. I was using a piece of software to rip large areas of satellite imagery from google maps and so the resulting maps were around 10k. From memory i`m pretty sure saving them as either bitmap and then converting to jpeg or using png worked.. And i`m using 8 gig rams here.. My guess is that reading the jpeg sometimes has to page a decompressed version to memory hence the problems..

Other than that, blah blah blah jpeg2000..

Website | Blog | Contact | Vimeo

read 1718 times
12/23/2011 11:03:51 PM (last edit: 12/23/2011 11:03:51 PM)
show user profile  magarlick
Thanks for the replies so far. Tried converting to JPG2000 but it takes an age, and then no program except PS can read it. If I open Windows explorer to view the file, it crashes when I navigate to its directory. Only way to delete it so I could see my files again was using Command Prompt.

Tried converting the JPG to BMP then back to JPG. No joy there either.


Mark Garlick Words and Pictures Ltd
read 1714 times
12/23/2011 11:17:23 PM (last edit: 12/23/2011 11:17:23 PM)
show user profile  thegunslinger
I have the some probleme with the arroway textures file...when i want to a big ong file the memory error appeer ..but I also don't understand why the specular and bump map appear in the preview screen and not the diffuse map of those files !!!!!!!!!!
read 1672 times
12/27/2011 2:50:25 PM (last edit: 12/27/2011 2:50:25 PM)
show user profile  thegunslinger
Can someone help me plz ???
read 1671 times
12/27/2011 2:51:33 PM (last edit: 12/27/2011 2:51:33 PM)
show user profile  thegunslinger
Ah yes am using 3ds max 2011 32bit versin ; if i use the 2012 can i avoid this probleme ?
read 1670 times
12/27/2011 2:58:20 PM (last edit: 12/27/2011 2:58:20 PM)
show user profile  advance-software
got a jpeg-2000 plugin that ships as part of our sdk. it's not locked down so use it if u like.

my guess is the jpg converter needs to create an intermediate buffer while decompressing that the other formats don't need. j2k decompression does something similar so might not be any help to you in this scenario. you really want an 8GB 64 bit machine/os if you're throwing around large images.

> Tried converting to JPG2000 but it takes an age, and then no program except PS can read it.

max can read j2k maps using our plugin. got a GIMP plugin kicking around too which anyone using that is welcome to use (it's open source). there are windows explorer plugins on the net that enable desktop thumbnails from j2k's etc . just not standard tech on windoze yet so you need to install a few bits & pieces.

set the 3GB switch to give max access to more memory on 32 bit windows (you can look this up).

your other option is to scale the bitmaps down a bit - 1024x1024 maybe on a low end system. will reduce image quality but you don't have much choice if you don't have enough memory.
read 1662 times
12/27/2011 3:26:55 PM (last edit: 12/27/2011 4:01:56 PM)
show user profile  thegunslinger
WHY DOES THOSE JPGS ARE READED BY SKETCHUP ????? AND WITH VRAY SKETCHUP ???? I THINK that there is a better solution but how ???
read 1641 times
12/27/2011 11:01:19 PM (last edit: 12/27/2011 11:01:19 PM)
show user profile  Bolteon
different memory management for different programs... AS is probably right that there's a buffer of information being needed when moving the encoded jpg file to something not encoded. the 5k in size makes an issue on 32bit systems.

try it with 64bit, should be fine.

either way, you shouldn't be complaining much about the size of the textures if your using 5k images... just saying. can't have your cake and eat it too every time (if you're not willing to go and get the proper hardware/software aka 64bit)

-Marko Mandaric

read 1638 times
12/27/2011 11:07:59 PM (last edit: 12/27/2011 11:09:23 PM)
show user profile  advance-software
have you set the /3GB switch yet ?

if not try that. if that doesn't give you enough resources, upgrade to a 64 bit system.

max uses more memory than sketchup so that's why one fits in what you have & the other doesn't.

read 1624 times
12/28/2011 12:50:14 PM (last edit: 12/28/2011 1:25:16 PM)
#Maxforums IRC
Open chat window