Forum Groups
  All forums
    Help & Feedback
      Work in progress
      Finished Art
      Non-Max related

Maxunderground news unavailable

[krakatoa] Can't see my teapot after Use Lighting
show user profile  w00
I have Krakatoa installed (big thanks to the people who helped me in my last topic and MXS too for the extra info i needed), and now i'm trying to play around with it. But i'm stuck at some point.

I followed the demo tutorial of krakatoa where he dissolved the teapot into particles.
So i create a teapot, with the particle view editor i created a new PF Source, added a Birth, Position, Force and Display. All are set correctly like he does in the tutorial.

When i render the teapot out then all i get is the teapot with NO shadings / lightings. Which is correct so far.

Now i added a Target Light aiming on the teapot and enabled the option "Use Lighting" in Krakatoa. But when i render it out now my teapot is almost not visible. It's waaay to dark...

So i was hoping anyone here could tell me what i was doing wrong...
read 1663 times
8/10/2009 9:37:57 AM (last edit: 8/10/2009 9:37:57 AM)
show user profile  w00
Well, actually i just noticed the problem. The particles of my teapot are alway black. Even when i use the option "Override Particle Colors"... Any idea why it stays black???
read 1657 times
8/10/2009 9:42:07 AM (last edit: 8/10/2009 9:42:07 AM)
show user profile  ScotlandDave
Self-illuminated material on them suckas?

Website | Blog | Contact | Vimeo

read 1640 times
8/10/2009 10:55:36 AM (last edit: 8/10/2009 10:55:36 AM)
show user profile  w00
I'm not sure about that. In the tutorial it just looks like an newly created teapot, with no extra materials on it.

This is the tut i'm talking about, maybe anyone else knows??

Self-Illumination didn't work. I still have black particles.
read 1634 times
8/10/2009 11:16:24 AM (last edit: 8/10/2009 11:22:45 AM)
show user profile  MXS
First of all, Self Illumination was not supported in Krakatoa 1.1.x, it is supported in the new v1.5.0 though.

The rules are these:
If you have a standard PFlow, the color defined by the Display operator should appear on the particles by default (it defines the wireframe color of the Event where the particles live).

If you want to quickly override the color of all particles regardless of their source, you can use the Color Override options in the Krakatoa UI (in 1.5, they were moved to a separate Global Render Values rollout, but in 1.1.x the override color is in the Main Controls rollout). If you set the color to write, you should get white particles.

You can also assign a Material operator to the PFlow and use a Standard Material to define the Diffuse color used on the particles.

Keep in mind that the Density settings in the Krakatoa Main Controls rollout also affect the appearance of the particles. If you have too many particles on the surface of an object and the Density is too high, you might get a lot of self-shadowing (and Moire effects) - the best solution is to distribute the particles within a narrow band around the surface instead of all exactly on the surface or to reduce the density, esp. the Lighting Pass Density. This is explained here:
In general, Density should be tweaked so that a single particle does not appear as a completely opaque pixel, but blends with many other particles to provide the final color (unless you are simulating solid particles like sand or something).

Posting a screenshot of what you are getting might be useful to try to determine the issue...

read 1568 times
8/16/2009 12:08:41 AM (last edit: 8/16/2009 12:08:41 AM)
#Maxforums IRC
Open chat window