Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography



Maxunderground news unavailable

I'm a n00by n00b n00b n00b. (Particle Flow)
show user profile  Dave
Ahoy hoy,

The problem:
Cannot scatter objects along a surface normals

The obvious solution:
Use a "Speed By Surface" operator, with mesh selected. Also set Rotation operator to speed space.

The problem:
It's not working as expected!

Any ideas?


"I flew over Egypt once"

read 500 times
8/7/2009 6:38:40 AM (last edit: 8/7/2009 6:38:40 AM)
show user profile  Nanne
Moving particles along the mesh or just placing them? Have you tried the Position Object Operator set to Surface?

Kristoffer Helander
www.kristofferhelander.se
  :: Works ::   |  :: Resumé ::   |  :: Contact ::   |  :: CG Blog ::   |  :: Links ::     
read 491 times
8/7/2009 6:50:37 AM (last edit: 8/7/2009 6:50:37 AM)
show user profile  Dave
Sorry, I had to rush that post as I was called away while writing it. Nothing is animated, I just need to scatter groups. It's worked before using the same event of operators so I'm confused as to why it's now not. I figure I'm missing something. My flow looks like this:



Edit
Whilst we're on the subject, is it just me or does the "Keep Apart" operator do nothing? My particles collide no matter what settings I fiddle with in there.

"I flew over Egypt once"

read 486 times
8/7/2009 6:53:10 AM (last edit: 8/7/2009 6:54:17 AM)
show user profile  Nanne
If you just want your particles to stick to the surface as if planting trees or scattering rocks or something like that, then delete the Speed Operator or set the Speed Value to 0. You are birthing the particles from the mesh and then you are shooting them of the surface with the Speed Operator, so delete or disable it.

Kristoffer Helander
www.kristofferhelander.se
  :: Works ::   |  :: Resumé ::   |  :: Contact ::   |  :: CG Blog ::   |  :: Links ::     
read 472 times
8/7/2009 7:04:17 AM (last edit: 8/7/2009 7:04:17 AM)
show user profile  Dave
(late reply)

Cheers Nanne, I've always assumed the Speed By Surface operator was the way to go (speed is set to zero) but i'll try erasing it entirely at work tomorrow.

"I flew over Egypt once"

read 402 times
8/9/2009 5:09:34 PM (last edit: 8/9/2009 5:09:34 PM)
show user profile  Dub.
set the speed by surface speed to 0.01 otherwise there is no direction vector for the speedspace rotation to work with.


read 398 times
8/9/2009 5:12:22 PM (last edit: 8/9/2009 5:12:40 PM)
show user profile  Dave
Aha! Cheers Dubbles, works a treat. Just in time for the morning-fix too!

"I flew over Egypt once"

read 374 times
8/10/2009 4:27:00 AM (last edit: 8/10/2009 4:27:00 AM)
#Maxforums IRC
Open chat window


Support Maxforums.org