Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography



Maxunderground news unavailable

Heavy noise in shadows (3Ds Max V-Ray )
show user profile  McArno
Hi, I have a problem with heavy noise in shadowed areas of my scene. It is not so strong in beauty pass, but is massive in VRayRawLighting and - Shadow passes (see images attached to the post), so it becomes a problem when compositing them later in photoshop.

I would really like to know, what is causing this kind of noise, when my render settings are set relatively high (see images attached to the post). And also my lighting has quite high subdiv values: VRay domelight with 64 subdivs and VRaySun with 45 shadow subdivs.

Any ideas would be greatly appreciated!

Beauty pass:
CLICK HERE FOR IMAGE
Render settings:
CLICK HERE FOR IMAGE
VRayRawLighting:
CLICK HERE FOR IMAGE
VRayRawShadow:
CLICK HERE FOR IMAGE
read 14804 times
1/22/2014 11:24:58 PM (last edit: 1/22/2014 11:30:00 PM)
show user profile  BishBashRoss
Check for overlapping/duplicate geometry.





read 14793 times
1/22/2014 11:43:55 PM (last edit: 1/22/2014 11:44:17 PM)
show user profile  mike_renouf
I'd try this:

uncheck "use DMC sampler thresh."
Change "Clr thresh" to 0.001
Reduce max subdivs to about 10 and see how you get on.

That way your lighting solution isn't as heavy, but the antialiasing of colour noise might clean up.




read 14783 times
1/22/2014 11:47:04 PM (last edit: 1/22/2014 11:47:04 PM)
show user profile  donvella
if its not overlapping faces, just increase subdivs on your light

edit: I would agree that it is overlapping faces.

Also, his global subdivs are set to 1... I would be looking at the light subdivs after and put it on atleast 30




read 14778 times
1/23/2014 12:09:18 AM (last edit: 1/23/2014 7:23:52 AM)
show user profile  BishBashRoss
I wouldn't be so quick to discount a geometry issue. If you take a look at his sub div values they are very high. First thing I check when I see stuff like this is geometry problems, then check for any non Vray materials.





read 14764 times
1/23/2014 1:31:13 AM (last edit: 1/23/2014 1:31:13 AM)
show user profile  McArno
Thanks for suggestions, I managed to reduce the level of noise, but it's still visible :/. (see image attached to the post)

What I tried and worked a bit was: 1. Unchecked "use DMC sampler thresh." 2. Changed "Clr thresh" to 0.001. But reducing the lights subdivs to around 10 didn't (if it were vraylights subdivs you meant?)
I also checked for duplicate/overlapping geometry, but that's not the issue here.

For clarification of results I added a comparison screenshot of VRayRawLigthting pass.
Comparison_of_results.jpg
read 14733 times
1/23/2014 1:08:46 PM (last edit: 1/23/2014 1:16:38 PM)
show user profile  BishBashRoss
Something doesn't look right to me. If you simplify the scene does the problem persist. If so you could upload here and we could take a look.





read 14723 times
1/23/2014 5:35:46 PM (last edit: 1/23/2014 5:36:23 PM)
show user profile  mike_renouf
I meant to change the max subdivs level to 10 - not alter the subdivs for each individual light (which should be somewhat higher I suggest.

There are some good tutorials on vray settings here:http://www.youtube.com/watch?v=lFyqidvb1G4

As Ross and donvella have been saying though, there maybe something fundamentally incorrect in your scene geometry or setup.




read 14712 times
1/23/2014 6:16:08 PM (last edit: 1/23/2014 6:16:08 PM)
show user profile  McArno
I simplified by: trying to render without HDRI texture, which gave no other result than a lighter scene overall. I also replaced mapped materials with basic VRayMaterials, and still not much success, only the wooden part got better, but the doors still had noise.

I'll add the model file to download, maybe someone can figure it out then: http://www.speedyshare.com/ED4M9/Containerhouse-2010version.max

read 14706 times
1/23/2014 7:48:45 PM (last edit: 1/23/2014 7:48:45 PM)
show user profile  donvella
Mike, if you have some time I would recommend this article which was posted about a month ago. It explains why increasing light, material & bf subdivs is a better option then using the clr thresh and global subdivs. It actually speeds up the render time by increasing the individual subdivs (or you could get VMC script which adjusts all your subdivs globally for individual lights, materials etc)

http://www.cggallery.com/tutorials/vray_optimization/

I used to use the clr thresh instead of the dmc sampler (which works well but is not very economic for the renderer - same with the global subdivs which increases all subdivs by the same amount which is not necessary if you only need 30 for your lights and 48 for your materials)

edit: keep using it if its working for you btw, I just thought id share something I learned recently.




read 14697 times
1/23/2014 11:42:54 PM (last edit: 1/24/2014 2:34:27 AM)
show user profile  McArno
Thanks for sharing that good article, gained quite a lot of new knowledge.

In the light of the article I tried more subdivs in lights, which meant that at about 500 subdivs in VRayDomeLight and VRaySun, I got reasonably noise free results on doors and in the shadow of the building. But that's probably too high amount of subdivs to use, in respect to render speed at least?
read 14678 times
1/24/2014 8:08:22 PM (last edit: 1/24/2014 8:08:22 PM)
show user profile  donvella
80 would be the max you need, if you follow each step of the tutorial you will find it should be noise free at each interval. (or more-so focussed on reducing the samples at each interval)





read 14668 times
1/25/2014 3:27:44 AM (last edit: 1/25/2014 5:10:47 AM)
show user profile  Error404
One thing to keep in mind, the raw lighting and other render channels (especially other RAW channels) will not be perfectly smooth most of the time. By default, VRay uses the RGBA channels to derive it's sampling from. This is how VRay is optimized. The render times would be much slower if all the other channels were used to calculate the sampling. When VRay determines that the RGB of the image is within the threshold that you've given it, it stops throwing samples, regardless of what the other channels look like.

You can force some of the other channels to be used in the sampling calculation, but off hand I don't think any of the raw channels are one of them. You could use an extratex channel, throw a fine noise texture on it, and force that channel to be used in the sampling calculation, however your render times will go up. I'm not sure the exact step-by-step of this in 3dsMax, I've only done it in Maya, but I assume you can do it in Max as well.


I wouldn't worry about it unless you are noticing the noise in the RGB, ore are using the other channels for heavy color correction. It's hard to tell with the compression on your image, but it looks like the RGB of your image is not noisy?

If you do need a very clean raw light pass for heavy color corrections, or how-to renders, what I would do is simply override your shaders to be a grey color, and render that as the RGB. That will more than likely render much faster than when you are trying to cram all the samples into the main render just to get your RAW light pass to be smooth.

www.DanielBuck.net - www.DNSFail.com

read 14652 times
1/25/2014 3:19:32 PM (last edit: 1/25/2014 3:40:14 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org