Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography



Maxunderground news unavailable

Getting max to display normals nicely?
show user profile  capone
I get weird black lines, awful shading on my normals in max. How can I make this look more matte and less shiny?
Have tried Niterous direct x 9 and 11. Using default built in normal map shader for max. Tried creating new lights and having those light the scene. All polys are set to 1 smoothing group.

or should I just use something like Marmoset?
read 473 times
8/27/2014 5:11:57 AM (last edit: 8/27/2014 5:13:36 AM)
show user profile  herfst1
add an edit normal modifier. Select "vertex" press ctrl+a and click "reset normals."
read 460 times
8/27/2014 1:05:29 PM (last edit: 8/27/2014 1:06:14 PM)
show user profile  Sir_Manfred
Turned off gamma-correction?



Visit my Portfolio
http://www.Freds3D.com

read 449 times
8/27/2014 5:17:43 PM (last edit: 8/27/2014 5:17:43 PM)
show user profile  digital3ds
add a light to the scene, then do a backflip

- Mike Sawicki




read 445 times
8/27/2014 5:23:03 PM (last edit: 8/27/2014 5:23:59 PM)
show user profile  herfst1
Nope, all wrong. It's normals fucking wit the scene.
read 436 times
8/27/2014 6:01:25 PM (last edit: 8/27/2014 6:01:25 PM)
show user profile  capone
herfst, nope tried it but it's all good and the normals are acting correctly.

Manfred, Gamma is on

digital, same problems with default lights and my own lights

:(
read 413 times
8/28/2014 2:05:12 AM (last edit: 8/28/2014 2:05:12 AM)
show user profile  herfst1
Hmmm, not sure you did it right... I'll take your word for it.

Alright, noob checklist (apologies, don't know your level):
1. Press 3 for border sub-mode and press ctrl+a. If you got red lines anywhere, you've got unwelded verts. Press ctrl+1, then click weld.
2. right click on object and select "objects properties," then tick "backface cull." if you have see-through faces you got flipped faces. You can add a "normalise" modifier and unify faces. Or just select the flipped faces and press "flip" (then try rewelding if it wouldn't weld before).
3. Click the [+] in the top-left of your viewport and select "configure viewports. Now select "lighting and shadows" tab, and select either "scene lights" (if you have lights in your scene) or "default" -> "1 light."
read 406 times
8/28/2014 3:16:28 AM (last edit: 8/28/2014 3:16:28 AM)
show user profile  Sir_Manfred
Turn off gamma.
You don't want it to do gamma-correction on the normal-maps. They will get funky.



Visit my Portfolio
http://www.Freds3D.com

read 399 times
8/28/2014 10:41:43 AM (last edit: 8/28/2014 10:41:43 AM)
show user profile  capone
It was gamma! Turned it off and now it looks great. Thanks for the checklist though herfst, good things to know if I get similar problems in the future.

What IS gamma? I know there are wikis on it etc but in the context of 3dmax and normal mapping what is it doing? So are you supposed to use gamma in general but when checking normals you turn it off? Is that standard practice?
read 386 times
8/28/2014 4:04:18 PM (last edit: 8/28/2014 4:04:18 PM)
show user profile  herfst1
I don't know about this gamma stuff, thought it was just for rendering purposes. Manny! Explanation.
read 380 times
8/28/2014 5:36:23 PM (last edit: 8/28/2014 5:36:23 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org