Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography



Maxunderground news unavailable

 
First page  Go to the previous page   [01]  [02]  Go to the next page  Last page
 
FRACKING Windows 10... UAC and metro
show user profile  ccampbell
Shits bad people. I mean. I've used it plenty helping others n stuff but this is the first time I've run it on my personal machine longer than a day and for good F*cking reason....It is really truly awful.

Total disregard for tech users and the novice a like. In fact, it feels like they've gone out of the way to make things very hard to find and while hugely reducing what can even be done by users to begin with. All the while requiring personal information to be relinquished short of command line and registry changes that very few are capable of or even willing to attempt to change.

It feels like the entire UX is guided on rails, like, apple Contracted out Jony Ive to fuck up windows 10 as bad as he has the latest apple stuff.
---------------------
ANYWAY... I didn't just come to bitch. I genuinely need help..

So all of my scripts that require any kind of command line access or writing to the hard drive like save files, rendered images, text files etc... via script are totally broken due to windows 10 UAC.

1) Fully disable UAC > Break all native and metro windows 10 apps.

2) Reduce / enable UAC at all > Can not use scripts that require command line access, writing to local drives or network access.

From what I gather you can NOT disable UAC entirely or enough to allow writing to the drives without UAC prompts without also breaking metro apps entirely. It seems to be Either - Or.

Tried

1) Reducing UAC Slider in user accounts entirely(this is perfect for win 7) - Requires admin prompt to save to local disks or use the command line.

2) Disable from Control Panel/ Administrative tools / services - Disables metro apps entirely

3) Turning off UAC in Registry - disables metro apps entirely

4) Compatibility ( Run Max as admin) - Maxscripts work OK now but sill requires prompts for any scripts using command lines and network access is still disabled through scripts / cmd

5) Last resort was a powershell removal of UAC elements via cmd line - broke all metro apps still and forced a reboot and windows updates which you can not control when its performing system crital operations in windows 10...

*Mine is the only account on this computer with full admin privileges.

--------------------
Any Ideas or links to a possible solution would be greatly appreciated if any of you guys have run into this issue your selves. I do a a lot of programming and Max script is just the start of these problems.

p.s.
Did you know that default picture viewer is a built in metro app? Yeah.. so that means If i disable UAC I can no longer view images in windows without 3rd party software....




$Entrepreneur = if((Designer + Engineer)*Programmer){Problem Solver};



read 737 times
1/16/2016 9:45:01 PM (last edit: 1/16/2016 9:48:26 PM)
show user profile  FX
I had the very same issue, I couldn't save my max UI settings.

Take control fixed it :
http://www.tenforums.com/tutorials/3841-take-ownership-add-context-menu-windows-10-a.html

When I get the time I'm putting win 7 back on, 10 is fucking awful, ugly, unfinished and constantly fucking things up for me in one way or another, I'm sick of it.

Win 7 is the new XP :)



read 727 times
1/16/2016 11:01:00 PM (last edit: 1/16/2016 11:01:00 PM)
show user profile  gogodr
Right click, run as admin.

Hello there

beautiful ;3


read 722 times
1/16/2016 11:21:50 PM (last edit: 1/16/2016 11:21:50 PM)
show user profile  Bolteon
^ mic drop.

-Marko Mandaric



read 717 times
1/16/2016 11:33:19 PM (last edit: 1/16/2016 11:33:19 PM)
show user profile  ccampbell
@FX Thanks for the TakeControl info. I'll have a try with that It may help with forcing admin mode which is disabling mapped network drive and cmd line access.

I may have accidentally discovered a solution thought. If I make a new folder on the C: drive manually I don't get prompts working inside that directory. likely due to my having inherently provided permission for this directory. Strange but it seems to be working. .

@gogodr ^ #4 . If you run as admin mapped network drives dissapear i.e. scripted network access and I still cant use the cmd line api.




$Entrepreneur = if((Designer + Engineer)*Programmer){Problem Solver};



read 712 times
1/16/2016 11:49:18 PM (last edit: 1/16/2016 11:49:18 PM)
show user profile  gogodr
network drives are mapped to the user.
To fix this open a command prompt as administrator an map the drives to the admin too.
But as a pro tip, dont do this. It is bound to have some kind of network failure and you will lose a file or have its data corrupted one of this days. Do a local copy and then transfer it through the network...
thats of course unless you actually have a NAS full of Serial SCSI hard drives, then you are safe.


'''
you have more problems than this, my first question is: if you are using windows 10, why are you suffering so much with metro apps? why not just use regular desktop apps?

when metro apps were introduced in windows 8 there was a new programming interoperability paradigms introduced along, but not many developers actually used.
Windows made a toolset to make interoperability easy with a framework of communication cross apps, so that you would never have to face problems like what you are experiencing right now.
Max is not a metro app, if you want to mix it with a metro app it is practically like trying to mix 2 different OS that coexists within the same machine, you will need some kind of bridge.

Hello there

beautiful ;3


read 695 times
1/17/2016 4:06:50 AM (last edit: 1/17/2016 4:13:55 AM)
show user profile  ccampbell
I definitely disagree here gogodr. As computer tech of 11 years up until just a few years ago I was a certified compTIA A+ & N+ Tech and certified repair tech for sony, toshiba and dell I can confidently say with out doubt that there's nothing wrong with working from mapped network drives.

Correctly set up networks are EXTREMELY reliable.

A mapped network drive is simply nothing more than a permanent shortcut to network location or drive and is as reliable as your network and hardware. A NAS with hot swaps which you refer too have no impact on network transfer success or connectivity. Only speed and redundant data back which we have so losing files is not a concern.

Here, we all work on a lot o the same files and our scripts need to be robust enough to work across all machines and our network and the web so sorry to say it snot always so simple.

I have no trouble with or use for metro apps to be honest. I do rather like the weather tile in my start bar though but that's not the point. They are here to stay and like it or not we'll all have to use them occasionally so I should not have to intentionally break them to use software that has nothing to do with them.

--

All of that said I've managed to get things working mostly and we can atleast get back to work for now but there are still issues with rights to copy files from one network location to another.




$Entrepreneur = if((Designer + Engineer)*Programmer){Problem Solver};



read 684 times
1/17/2016 6:07:02 AM (last edit: 1/17/2016 6:07:33 AM)
show user profile  gogodr
With a serious business infrastructure I see no problem. I only speak from personal experience and what happened to me might not happen to you.

In my lab we developed our of solution for storage with a pretty robust cluster we made ourselves that served user sessions and main storage, and our network became a little overloaded. (thats the diagnostic after almost half a year of not knowing what was the problem)

we worked directly with the server as a main file storage and it was fine the first year, but then it started becoming unreliable. We were not using anything fancy so if you have a robust infrastructure it should be no problem. a NAS or SAN sin SCSI hard drives is way more reliable because this drives are made specially for servers that handly a lot of connections. They have their read and write channels separated instead of shared as in normal SATA drives and also they have embedded parity check and recovery so that in the case of an incident the drive itself will look if the gotten data is enough to be restored.
------------

back to the metro apps: my suggestion was, if you are building a plugin for max that you want to run as a metro app, you will have to make a bridge of communication, because the robust interoperability of metro apps with other metro apps that windows launches with windows 8 doesn't extend to metro apps with desktop apps.
the workaround I made for this when windows 8 came out and I started messing around with metro apps, was to make a service with the desktop app and consume that service. (it was a websockets server running in a custom port and having the metro app connect to the service via websockets)

but it looks that you have that working already.

---------

as for the rights to copy files, might be something as simple of having to verify that the location read/write policies are configured correctly? and that your user is in the correct usergroup with rights over that location.

Hello there

beautiful ;3


read 680 times
1/17/2016 6:37:37 AM (last edit: 1/17/2016 6:37:37 AM)
show user profile  spoon
How about using the unc paths in your scripts? You should always try to avoid depending on any type of configuration in code/script.


read 671 times
1/17/2016 8:04:42 AM (last edit: 1/17/2016 8:04:42 AM)
show user profile  c0
Enabling is not an option, disabling is -no longer(*)- an option; 'relaxing' seems like the only option left:

http://www.ghacks.net/2015/08/22/make-uac-prompts-less-intrusive-on-windows-10/

(*) http://www.worldconquer.org/evil_overlord.html

read 666 times
1/17/2016 8:22:32 AM (last edit: 1/17/2016 10:15:30 PM)
show user profile  Bolteon
Panda.

(I'm drunk now)

-Marko Mandaric



read 641 times
1/17/2016 9:08:50 AM (last edit: 1/17/2016 9:08:50 AM)
show user profile  donvella
I feel your pain, I remember spending a week trying to find all the new buttons in windows 7 after I got so used to xp. However, I would have to say its the best thing Microsoft have done in years.

My bias aside, maybe some of this could help you, I wrote a procedure document for installing windows 10 accross our machines and we have no permissions issues with max or any software so far.

Install Windows 10
Activate Remote Desktop
Assign a PC Name for each Slave (eg Slave1 is named Slave1 in Computer Description [System Properties] and under “To rename this computer or change its domain or workgroup, click Change.” Change - Computer Name)
Start > type “Change User Account Control Notifications” > “Never Notifiy”
Start > Settings > System > Notifications and Actions > Select which icons appear on the taskbar > “On”
Assign Static IP Address
Check Homegroup as Private not Public
Map Network Drives
Copy Autodesk software and plugins to desktop & Install
Install latest version of backburner
C:\Program Files\Autodesk\3D Studio Max\3dsmax.exe > right click “Properties” > Compatibility > select “run as administrator” to enable
Launch 3ds max x2 to enable writing scipts to disk for RP Manager
C:\Program Files\Autodesk\3D Studio Max\3dsmax.exe > right click “Properties” > Compatibility > select “run as administrator” to disable
Setup Schedule for 6:30pm Server and Vray Spawner to enable
Install PDPlayer
Install Adobe CC - Photoshop, Illustrator, After Effects, Indesign
Install Draftsight
Install Office > Word, Excel, Powerpoint
Install Quicktime
Task Manager > Startup > Disable Onedrive and Autodesk Application Manager
Check Chaosgroup, Itoo, Backburner, RP Manager to point to License Manager
Create windows Restore Point
Start Menu > type "Backup" > Create System Image

alot of this you could probably skip, but the essentials are there

The only permission issue you may have is your max ui, but this is because for some reason in win10 it tries to save to C:\Program Files\Autodesk\3ds Max 2016. Save your preferences to C:\Users\"Username"\AppData\Local\Autodesk\3dsMax\2016 - 64bit\ENU\en-US\UI instead. This works as it should.






read 583 times
1/18/2016 7:21:13 AM (last edit: 1/18/2016 7:23:22 AM)
show user profile  ccampbell
Hey thanks a ton for all the great advice. I haven't had much time to look at it today but i'll be working on it tomorrow so i'll be sure to update.

@Spoon Great Idea. For better or worse I do all of the server work here so I configure everything to work but moving forward I'm definitely going to take this into consideration.

I spent about 15 minutes looking into this and it seemed that to use UNC paths in max you need to convert them from string paths pointing to a mapped drive.

uncpath = pathConfig.convertPathToUnc "K:\folder\thisfile.ms".

When using the converted string path result, stored in a variable I was able to do simple file checks like doesFileExist, size etc... but not much more. Manually writing a string pointing to a UNC path (i.e. "\\server1\folder\thisfile.ms" ) wasn't giving me anything. I'll need to spend more time here.

@c0 Thanks, I'll have a look and see if theres anything there I've not done.

@Bolteon Cheers!

@donvella This is a fantastic list. I see a few things I can try there immediately. Thank you for taking the time to put that together!


These are all really great Ideas guys thanks a ton for the feed back. I'll be sure leave update as things take shape tomorrow. Have a great night guys.





$Entrepreneur = if((Designer + Engineer)*Programmer){Problem Solver};



read 578 times
1/18/2016 8:38:23 AM (last edit: 1/18/2016 8:40:49 AM)
show user profile  FX
"The only permission issue you may have is your max ui, but this is because for some reason in win10 it tries to save to C:\Program Files\Autodesk\3ds Max 2016. Save your preferences to C:\Users\"Username"\AppData\Local\Autodesk\3dsMax\2016 - 64bit\ENU\en-US\UI instead. This works as it should."


Aha!, that's exactly what happened to me, didn't try enu folder...anyway irrelevant as I'm back on Win 7 until things improve with 10 (if that ever happens).





read 574 times
1/18/2016 9:18:02 AM (last edit: 1/18/2016 9:18:02 AM)
show user profile  ccampbell
Ok... Sorry for the delay in update post! As soon as things got up and running I had to take care of my back log.

Sooo.... Good news. I've since been able to get everything back up and running. The network path issue was totally related to having removed some code in a recent revision that effected a few scripts... This was the issue I thought to be causing copy permissions problems over the network.

This issue had broken several lines of code for an exporter and removed some escape characters which is what was leading to i/o errors and such...

@Spoon While testing UNC stuff I found some code I left commented out where I had tested UNC paths before. I think it comes back around to having to convert mapped drive paths to UN paths which is an extra step in my process really only because the network config is the way it is. I'll be updating this to be more robust in soon though.


@Donvella
I found a few nice tricks i'll be keeping in my pocket for future Windows 10 installs but otherwise I had done alot of what was on that list.

I never did figure out how to enable dynamic writing to the local drive in windows 10 without breaking metro too BUT... Since manually making the initial folder on the C: Drive to work from, I've not run into of the same write permissions so I'm considering this a win.


Thanks everybody for all the help. As usual, you guys rock!




$Entrepreneur = if((Designer + Engineer)*Programmer){Problem Solver};



read 489 times
1/22/2016 8:30:31 PM (last edit: 1/22/2016 8:32:07 PM)
 
First page  Go to the previous page   [01]  [02]  Go to the next page  Last page
 
#Maxforums IRC
Open chat window


Support Maxforums.org