Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(36 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

final gather issue - lost and frustrated
show user profile  digital3ds
I'm calculating fG maps to reduce some flickering issues during an animation

Here is the scene with teapot place holders


Photobucket


if I render a single frame this is what I get. If I then calculate the fG map for the 'current frame' and switch to 'read only' there are no problems; I get the same image, just faster because it doesn't have to calculate final gather

The problem comes when I switch to 'active time segment' (in this case 30 frames)... I use all of the same settings, click calculate fG, and max saves the 30 final gather maps to the renderassets folder, but now, when I switch to 'read only', go to frame 1 and render, I get this


Photobucket


Anyone ever experience this before?


- Mike Sawicki




read 909 times
9/26/2012 4:59:37 AM (last edit: 9/26/2012 4:59:37 AM)
show user profile  Coxy
What are your FG settings?

Are you using the camera along path segment method?

Are you rendering the FG map at the same resolution (Or taking steps to accomodate for the Density if not?)



www.artasmedia.com
read 900 times
9/26/2012 5:06:10 AM (last edit: 9/26/2012 5:06:10 AM)
show user profile  digital3ds
Photobucket


yea, you can see it being segmented behind the settings

the only thing I change between it working and it not working is under the common tab - from 'single' to 'active time segment'

*** I guess sometimes you just need to type it into maxforums for your brain to recognize the problem. I switched back to active time segment and it appears to be working.. going to test it with backburner to make sure

- Mike Sawicki




read 898 times
9/26/2012 5:19:31 AM (last edit: 9/26/2012 5:24:51 AM)
show user profile  digital3ds
yuuppp. works like a charm; only took 6 hrs to finger out. Still not sure why tho

If you render a 30 frame anim and then try to use a single fG map at say frame 20, it doesn't render properly... is this because of the "incremental" part of adding fG? seems like frame 20 should read the frame0020.fgm and work, da? fml

strange.. thanks coxy, if you hand't asked wouldn't have seen it
- Mike Sawicki




read 894 times
9/26/2012 5:43:39 AM (last edit: 9/26/2012 5:43:39 AM)
show user profile  Coxy
If you have a 30 frame animation, you need to be generating the final gather pass for all of those Nth frames still, even if you are using the 'project along camera path'. You can't render out just one frame. Glad you fixed it!



www.artasmedia.com
read 891 times
9/26/2012 6:03:02 AM (last edit: 9/26/2012 6:06:22 AM)
show user profile  digital3ds
I've been trying to fix this since yesterday..


Photobucket


"a" and "b" are the same object / same materials - the 2 renders are from the same frame -

"a" is of a group called anim01. This layer has a specific animation
"b" is of a group called anim02. " "

there's only one set of lights in the scene - these lights have no animation on them..
I'm rendering with the same settings.... I simply render a, then hide a, unhide b, render b.

How can the lighting in the render differ?

** group b was merged into the main scene from another .max file ((they were seperated to save file size)) - with that said - 'group b' was created from the main file, so the start time of group b was the end time of group a.. I noticed the problem when test rendering the end / begin of the two files.. I thought it was a difference in lighting, so I merged all scenes together to troubleshoot and i'm still getting the lighting issue here.. I have no idea y


Photobucket


Now I get this error when I try to use the key transfer script by JokerMartini at scriptspot .. 8 /
- Mike Sawicki




read 849 times
9/30/2012 7:17:36 AM (last edit: 9/30/2012 9:53:20 AM)
show user profile  donvella
I might be totally misunderstanding this but arent your objects placed in different locations? Or have you compiled the two render on top of each other? The reason I say this is your lights look closer to the center on a, and closer to the right hand side of b.




read 822 times
10/1/2012 4:12:56 AM (last edit: 10/1/2012 4:13:19 AM)
show user profile  digital3ds
nah.. the objects are in the exact same locations (that img was photoshoped) ... somewhere along the line I "included" only a few objects to that light (kicking myself)

I had to "include" the now duplicate objects (since I renamed them all "blah_anim02" to their appropriate scenes)

That corrected the dramatic difference in the above pic....

nooowwww, however, there appears to be slight differences in final gather... 'Slight'...
when I render them in the same scene, they're identical
when I render them in different scenes (.max files), they are slightly off

I need to finish this asap, so it's either troubleshoot anim02 ---> anim01, or fix it in post, and max is more or less locked up rendering the fG maps for anim01...

im thinking fix it in post, as I'm getting sick of these issues : ) <--- still pissed I don't know why its happening tho (the slight difference in img's)
- Mike Sawicki




read 816 times
10/1/2012 5:18:00 AM (last edit: 10/1/2012 5:18:00 AM)
show user profile  Coxy
Are you using the same FG map for both versions?



www.artasmedia.com
read 809 times
10/1/2012 6:00:17 AM (last edit: 10/1/2012 6:00:17 AM)
show user profile  digital3ds
it might be worth a try... I think what I'll have to do to use the same map is just copy (9 <-- since that is what my "divide along camera path" is set to) .fgm maps and rename them so the second file can read them *in the correct order*; I'm going to try that


this is the issue I'm talking about now ("slight difference")




- Mike Sawicki




read 807 times
10/1/2012 6:10:27 AM (last edit: 10/1/2012 6:49:45 AM)
show user profile  digital3ds
a new problem - rendering the final sequence and Im seeing this strange artafacting.. it only occurs for a few frames but I'm worried that it will happen at a more obvious section of footage

Any ideas what causes this? same settings as above


Photobucket


- Mike Sawicki




read 725 times
10/12/2012 11:35:17 PM (last edit: 10/12/2012 11:38:27 PM)
show user profile  herfst1
Long-shot: Could it be that you're checking the internet or using your graphics card in some way? I was watching an iray tutorial and the guy suggested using iterations rather than time-per-frame to render out animations because that eliminates any possibility of artifacts, for the reasons stated above.
read 718 times
10/12/2012 11:42:59 PM (last edit: 10/12/2012 11:42:59 PM)
show user profile  digital3ds
I have been whoring out my comp, but im rendering with MR, so idk if that would affect it?
- Mike Sawicki




read 715 times
10/12/2012 11:51:23 PM (last edit: 10/12/2012 11:51:23 PM)
show user profile  donvella
looks like a light cache issue




read 704 times
10/13/2012 6:05:37 AM (last edit: 10/13/2012 6:05:37 AM)
#Maxforums IRC
Open chat window


Support Maxforums.org