Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(36 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

Making environment maps invisible in render?
show user profile  Nithel
I'm using a glossy mental ray Arch & Design material on my objects, and a HDRi bitmap in the environment Map slot to generate the reflections.
Is there a way to make the environment map NOT show up in the background of my render, but still be reflected in the material? I just want it to render as an alpha that I can save in my .png, so I can replace it with a background in Photoshop.
read 3247 times
9/3/2012 2:15:57 PM (last edit: 9/3/2012 2:15:57 PM)
show user profile  Weetabix
Use the environment / background switcher material.

However, the environment background shouldn't turn up in the render when saved as a PNG with alpha, once the image is opened in Photoshop. You will probably find that what you are doing is ok.



read 3243 times
9/3/2012 2:19:07 PM (last edit: 9/3/2012 2:20:14 PM)
show user profile  Nithel
I didn't show up in photoshop, but I checked the alpha toggle in the rendered frame window, and sure enough there was one. Turns out I didn't check the "save alpha" when saving the .png.

Thanks for the help! And that environement/background switcher will surely come in handy one day :-).
read 3238 times
9/3/2012 2:29:56 PM (last edit: 9/3/2012 2:29:56 PM)
show user profile  threedee
if you want the environment on your object only, go to the mental ray Connection tab of your material and unlock the Environment option and select the Environment(3dsmax).
hit the Map button and get your image.

go to Render, Environment and r-click, clear that map you had in there.
This way the environment only shows up on the object.

HTH
read 3225 times
9/3/2012 4:27:16 PM (last edit: 9/3/2012 4:27:16 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org