Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(36 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

After Effects Trapcode Particular
show user profile  assegai
I'm using particular to create sparkles trailing a star, however when I render out the targa sequence the sparkles look all muddy, what do I have to do to get a nice clean transparency??

I know for lens flares they have xmult and unmult but they're not working for this.

Thanks
read 1235 times
3/23/2009 2:55:12 PM (last edit: 3/23/2009 2:55:12 PM)
show user profile  Dredwerkz
Think you could give us a screenie of the GUI and a rendered image?
read 1231 times
3/23/2009 2:57:25 PM (last edit: 3/23/2009 2:57:25 PM)
show user profile  assegai




read 1226 times
3/23/2009 3:08:20 PM (last edit: 3/23/2009 3:15:23 PM)
show user profile  Jollabollathan
Are you rendering against that bright red or the black (as in the last screenshot)? What are the alpha settings for your targa output? Premult or unmatted? Also what are the interpretation settings for the targa sequence once it's imported?

It looks like you're rendering with premultiplied alpha against black but your fotage interpretation is set to unmatted alpha, in which case you just need to change it appropriately.

read 1180 times
3/23/2009 4:44:41 PM (last edit: 3/23/2009 4:46:32 PM)
show user profile  Dr. Jim
bingo. Yup jolla,....that is exactly whats happening.

edit - I also notice you have particular on a 3D layer? Why would you do that? Not the best idea.
And whats with the unmult? You dont need that do you?
read 1147 times
3/24/2009 5:24:42 AM (last edit: 3/24/2009 5:26:25 AM)
show user profile  assegai
Thanks for the advice!

"It looks like you're rendering with premultiplied alpha against black but your fotage interpretation is set to unmatted alpha, in which case you just need to change it appropriately. "

How do I do that? And, I rendered over just the default black background. The pink shades were just to emphasize the problem.


" I also notice you have particular on a 3D layer? Why would you do that? Not the best idea.
And whats with the unmult? You dont need that do you? "

I don't know lol, and I thought applying the Unmult on the stars might help since it's designed to take the artifacts off of Lens Flares
read 1127 times
3/24/2009 6:39:38 AM (last edit: 3/24/2009 6:47:14 AM)
show user profile  Dr. Jim
Yes,....what you are showing there in your interface pic would render an image sequence WITH premultiplied alpha.
Now,...if you are going to take that sequence back INTO AE then when you bring it in just select premultiplied with black when it gives you the "interpret footage" dialog on import.

The unmult is to 'unmultiply' the black,...which would in theory work the same way as unmult on import. However,...in this case it wont work in the AE effect stack due to the way its processed. So it is doing nothing right now.

Also, the reason it helps with lens flares is because older versions of Knoll (or current AE lensflare I think) didnt premultiply or generate an alpha, a lensflare on a black solid would not have transparency and wouldnt key over the layers beneath it.....so unmult would allow it to key.

Particular operates in 3D space natively, taking advantage of AE camera...etc...etc....so it is NOT a good idea to use it on a 3D layer. If you move the 3D layer then Particular is actually being offset in 3space and will give highly unpredictable results. Dont do this. ;-)


read 1117 times
3/24/2009 7:07:29 AM (last edit: 3/24/2009 7:07:29 AM)
show user profile  assegai
Thanks for all that info


However I think I'm missing something, what settings do I need to change? When I click on interpret footage this is what I get, I have particular on a black solid.

I render the targa sequence then import into premiere.
read 1113 times
3/24/2009 7:19:42 AM (last edit: 3/24/2009 7:19:42 AM)
show user profile  Dr. Jim
Dude,.....something is missing in our communication.
For starters,...WHAT are you trying to do?

Why are you prerendering the particular?
Are you rendering the particular out to Targa files so you can use them in some other application?
WHY do you want the Targa's?

If you are creating some entire piece in AE,....then your particular is on a layer, and is combined with your whole piece?....And you would render out when done?

Why are you trying to just render the Particular?

All that aside...
IF YOU WANT to render the particles to a sequence WITH an alpha channel that will be brought back into AE and is keyable...
Set it up like the first pic you posted a couple replies above,....RGB+alpha,..etc..etc. Click "Format options" and make sure it is 32-bit,...NOT 24. (This gets alot of people initially).
- Render your targas.
- File - Import - load targa sequence back into AE (again...why?)...the interpret footage dialog should appear AUTOMATICALLY, and you would then select premultiplied, (leaving the color black in box).

This would work.


Sorry to belabor point,....but I cant possibly see why you want to render the particular to Targas and then bring them back into AE to use? Just use particular IN ae???

read 1108 times
3/24/2009 7:41:52 AM (last edit: 3/24/2009 7:43:03 AM)
show user profile  assegai
I'm compositing it into a 3d animation. 3dmax and Adobe Premiere, everything's composited in premiere. I just want to render some sparkles, import the targa into premiere and composite. No going back into after effects.It's part of a 3d logo, the client wanted sparkles on the stars. So all I need AE for is the sparkles.Particular on a black solid, render, done. Although I kept getting the black artifacts. I'm usually pretty good with this stuff but it had me stuck. Maybe it's a way i'm importing into premire? I just click import and targa sequence (the usual). Because I brought back my rendered targa sequence into AE to test it and it seems to work fine. When I bring it into premiere now it has the artifacts.
read 1105 times
3/24/2009 7:48:38 AM (last edit: 3/24/2009 7:48:38 AM)
show user profile  Dr. Jim
I am not that familiar with Premiere.
Another stupid, nosey question for you (curiosity...)...why not do the compositing in AE? It is much better for that than premier.....?

I am sure premier has a way to specify whether to use premultiplied or straight alpha....OR
You could render them from AE, and change that 'premultiplied with black' output setting to 'straight unmatted'......that should work too.....IF Premier 'wants' straight alpha....
read 1099 times
3/24/2009 8:29:20 AM (last edit: 3/24/2009 8:29:42 AM)
#Maxforums IRC
Open chat window


Support Maxforums.org