Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(37 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

after effects jpeg problem
show user profile  stevey2shoes
Hi
I want to overlay a jpeg onto a video in after effects, but do it in 3d space.
I've done it a few times but for some reason, this time, when I click the icon to say that layer is 3d, the surrounding goes black and blocks out the underlying video I wanted it to lay on.
Thought it might be a different image type but they were both jpeg so I'm confused,
any ideas
Steve
read 364 times
1/31/2012 1:12:25 PM (last edit: 1/31/2012 1:12:25 PM)
show user profile  9krausec
why are you making it a 3d layer first of all if it's just a jpeg? The only reason I've ever had to create a 3d layer out of a png, is to give the illusion that it was actually a 3D logo and not just a 2D plane (and I needed to use DOF w/ the camera (placed a few logos staggered and animated the cam).

edit: any lights in your scene? is it above your video in your stack?




- Portfolio-




read 349 times
1/31/2012 2:34:49 PM (last edit: 1/31/2012 2:35:44 PM)
show user profile  stevey2shoes
Hi
I'm trying to simulate/replace a billboard on a video with my jpeg. I've done it before without problem, but this time everything which is not jpeg is pure black.
There are no lights and it IS above the video in the stack.
in 2D form, you can see the video behind/underneath, its only when you click the icon to say its a 3D layer that everything else gets blocked out.
Steve
read 345 times
1/31/2012 2:45:34 PM (last edit: 1/31/2012 2:45:34 PM)
show user profile  Dr. Jim
In AE 3D space,....stack order is irrelevant. Only Z order is used in 3space.
Check that first off.

2nd off start applying some logical process to it.
create new comp.
bring in jpeg....turn on 3D,..what happens?
...etc....etc....


read 339 times
1/31/2012 2:59:32 PM (last edit: 1/31/2012 2:59:32 PM)
show user profile  stevey2shoes
Dr Jim, for some reason that worked.
just starting from scratch with only those 2 items it worked.
I did try deleting and re importing the picture but it did nothing will try again
Steve
read 332 times
1/31/2012 3:46:35 PM (last edit: 1/31/2012 3:46:35 PM)
show user profile  stevey2shoes
no deleting and re importing did nothing this time either, very odd, could it be composition settings? not that i ever change those
Steve
read 331 times
1/31/2012 3:49:00 PM (last edit: 1/31/2012 3:49:00 PM)
show user profile  9krausec
@Jim- agreed, but when you are using 2 elements one 3d and one 2d, then the order is relevant (which is what I was going for).




- Portfolio-




read 323 times
1/31/2012 4:20:26 PM (last edit: 1/31/2012 4:20:26 PM)
show user profile  Dr. Jim
ah!...You are correct,....I didnt catch that in OP reply.

stevey - not sure mate. Tis a very simple thing you are trying to setup.....should work no problem,....you must clicked somethin somewhere! lol

Just rebuild it

read 323 times
1/31/2012 4:27:38 PM (last edit: 1/31/2012 4:27:38 PM)
show user profile  stevey2shoes
ha ha "just rebuild it" he says.
its part of a piece I've been working on for about 6 months now, and he says " JUST" rebuild it.

I could just render that scene as is, and import THAT as already comped video file. ........ (just rebuild it he says)
just playing with you, seriously though, thanks for your help, would love to have got to the bottom of it though because as you know its a simple scene, what could go wrong?.


OOOh forgot to mention clicking that 3d button does turn the jpeg 90 degrees so you cant see it at first, does this offer any new leads?
Steve
read 318 times
1/31/2012 5:04:05 PM (last edit: 1/31/2012 5:04:05 PM)
show user profile  9krausec
Well, unless I'm missing something (new to AE), from what you described (the rotation of the object at a 90 degree angle when 3D option is applied), your camera is at a 90 degree angle from the scene.

This means that your zed is not back and forth, but left and right.... This may be causing some complications.




- Portfolio-




read 312 times
1/31/2012 5:20:50 PM (last edit: 1/31/2012 5:20:50 PM)
show user profile  stevey2shoes
I just fixed it accidentally (but educated guess), RIGHT CAMERA was selected not ACTIVE CAMERA, now I've clicked that all is well.
I genuinely didn't see 9krausec's post until after but it seems he's phrased this another way round. I'm just glad I got to the bottom of it
thanks everyone
Steve
read 309 times
1/31/2012 5:44:23 PM (last edit: 1/31/2012 5:44:23 PM)
#Maxforums IRC
Open chat window


Support Maxforums.org