Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(37 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

 
First page  Go to the previous page   [01]  [02]  Go to the next page  Last page
 
Does anybody use Composite?
show user profile  Nik Clark
As per the title, does anybody here use Autodesk Composite? I've been using it today to put some stuff together, but I have questions I can't figure out the answers to.

Cheers.



read 936 times
6/29/2011 11:20:27 AM (last edit: 6/29/2011 11:20:27 AM)
show user profile  br0t
dunno if it is of help, but paul neale recently posted a long tutorial video on composite http://paulneale.com/tutorials/composite/composite.html

never get low & slow & out of ideas


read 927 times
6/29/2011 11:27:57 AM (last edit: 6/29/2011 11:27:57 AM)
show user profile  Nik Clark
Thanks Br0t!

To continue, I need output from Max in Composite. I need to blend an alpha channel of my render, with ambient occlusion, shadows and glare data from MR.

I've figured out how to composite things together (what a bizarre program, it doesn't seem to follow the Windows paradigm at all), but I don't know what the recommended workflow is to do this sort of thing.




read 925 times
6/29/2011 11:28:13 AM (last edit: 6/29/2011 11:28:30 AM)
show user profile  Nanne
I use Composite and kind of like it; but yes, it is a bit bizarre in some ways :P

I'm not sure I understand the problem.

Have you tried just combining them with the Blend&Comp Node?

There is a Set Alpha Node if you need to add an grey scale image as an alpha to another image. There is also a Rewire Node.

But again, I'm not quite sure of the problem you are having; be more specific :)

Cheers!

Kristoffer Helander
www.kristofferhelander.se
  :: Works ::   |  :: Resumé ::   |  :: Contact ::   |  :: CG Blog ::   |  :: Links ::     
read 914 times
6/29/2011 12:01:15 PM (last edit: 6/29/2011 12:01:15 PM)
show user profile  Nik Clark
Hi Nanne,

Yes, I've been playing with the Blend&Comp mode. I've only been using it for about an hour, so I'm still finding my way round it.

It was more a question of the common workflow between max and Composite. Does one simply output all the different render elements, then pull them back together in Composite, or is there another way of doing it? Also, what file types are the best to use for Composite? I tried using EXR, but Composite doesn't like it. At the moment, I'm outputting TIFFs.




read 899 times
6/29/2011 1:14:47 PM (last edit: 6/29/2011 1:14:47 PM)
show user profile  Nanne
EXR no question! :) Composite is more or less built for 32bit and EXR workflow. So that's the way to go.

I use Render Elements in the channels of my EXR and sometimes I render in passas/layers using LPM (http://www.lukashi.com/LPM.php) but then I use different EXR. But EXR and Composite works great.

Edit: Make sure your EXRs are saved with the Storage Type set to "Tiles" (not Scanlines) Composite prefers Tiles (Nuke prefers Scanlines, I think)

What problems are you having with your EXRs?

Kristoffer Helander
www.kristofferhelander.se
  :: Works ::   |  :: Resumé ::   |  :: Contact ::   |  :: CG Blog ::   |  :: Links ::     
read 884 times
6/29/2011 1:51:24 PM (last edit: 6/29/2011 1:58:36 PM)
show user profile  Nik Clark
Damnit, I am full of fail today.

If I create a render element and set it to EXR, it doesn't save the file. If I choose TIFF, TGA, PNG, etc, it saves the file. I've chosen 32bit, tiles.

Any thoughts on why it's not saving the files?



read 846 times
6/29/2011 3:15:53 PM (last edit: 6/29/2011 3:15:53 PM)
show user profile  Nanne
Have you assigned the Render Elements in the OpenEXR Dialogue or told it to Auto assign them?

By the way: 16bit Float is good enough, same quality but much smaller file size.

Kristoffer Helander
www.kristofferhelander.se
  :: Works ::   |  :: Resumé ::   |  :: Contact ::   |  :: CG Blog ::   |  :: Links ::     
read 838 times
6/29/2011 3:41:19 PM (last edit: 6/29/2011 3:41:19 PM)
show user profile  Bolteon
no.



and never will.

-Marko Mandaric



read 835 times
6/29/2011 3:43:45 PM (last edit: 6/29/2011 3:43:45 PM)
show user profile  Nik Clark
I chose auto assign. Perhaps that's where I'm going wrong.

Marko, boy could I use your brain today. I've never done compositing like this before. I have to admit, I generally do stills, and use Photoshop. Amateur hour here.



read 831 times
6/29/2011 3:47:26 PM (last edit: 6/29/2011 3:47:26 PM)
show user profile  Bolteon
get yourself a 15 day trial of nuke and i can slap something together for you real quick...

http://www.thefoundry.co.uk/products/nukex/try/


-Marko Mandaric



read 828 times
6/29/2011 3:52:37 PM (last edit: 6/29/2011 3:54:08 PM)
show user profile  Nik Clark
That's very kind of you. I'll have a word with my boss and see if Nuke might be a possibility for us. If not, I can try the demo.





read 824 times
6/29/2011 3:57:46 PM (last edit: 6/29/2011 3:57:46 PM)
show user profile  Bolteon
yeah, there's a reason why composite is thrown into the mix for free... not exactly the best when it comes to compositing.


let me know, and shoot me an email: marko (dawt) mandaric (awt) dot3studios (dawt) com

-Marko Mandaric



read 816 times
6/29/2011 4:13:47 PM (last edit: 6/29/2011 4:13:47 PM)
show user profile  Nik Clark
Email sent, Marko. Thanks for the help.

1) Is it possible in Max to render out an alpha channel of a single object without hiding all the other objects? I've scripted it so it's not much of a chore, but it would be easier if I could set up an alpha pass for a single object in the render elements.

2) Are any of the Render Elements the equivalent of what you'd get if you hit render.

Total newb time here.





read 775 times
6/30/2011 10:06:17 AM (last edit: 6/30/2011 5:22:24 PM)
show user profile  reeves1984
Sounds like thats where max misses proper passes :/ sillyness

Nuke is good.

--
Simon Reeves


www.simonreeves.com - VFX Artist & Blog
twitter


www.analogstudio.co.uk <-- I work here

read 771 times
6/30/2011 10:25:13 AM (last edit: 6/30/2011 10:25:13 AM)
 
First page  Go to the previous page   [01]  [02]  Go to the next page  Last page
 
#Maxforums IRC
Open chat window


Support Maxforums.org