Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography



Maxunderground news unavailable

Curing Z-fighting in Perspective view.
show user profile  bigwilk
Hi guys,

I've registered here after failing miserably to find a solution to my problem. I'm making large scenes in 3DS MAX (2009 Design, SP1, 64Bit) with structures imported from Revit. However, I seem to have terrible z-fighting issues whenever I look at the models in a perspective viewport. Since I do a good chunk of my modelling in perspective this makes it really frustrating since I have to switch views or do a render to tell whether a wall (for instance) that I've made is actually outside of the structure.

This shows what I'm seeing on a useful zoom. If I zoom right in or out then it looks right, but is useless to me (below image shows what it actually looks like)

I've tried DirectX 9/10 (although 10 doesn't work for me...that's a whole other issue I can avoid) + OpenGL + software and have the same issue with all. Also tried 32/64 bit and had same issue on both Win 2000 and Win Vista 64. I'm praying I've just missed some checkbox somewhere that says something like "spend more time on depth processing" but damned if I can find it.

Any help would be greatly appreciated!

Thanks
read 2049 times
2/26/2009 6:01:58 AM (last edit: 2/26/2009 6:01:58 AM)
show user profile  Stephen R.
Make sure your scale is correct, this usually occurs when your scene is too big your too small by a drastic measure. Throw a tape measure in you scene and make sure you are working at the correct scale.





read 2043 times
2/26/2009 6:04:00 AM (last edit: 2/26/2009 6:04:00 AM)
show user profile  bigwilk
Well the scale is correct, however the numbers can be big depending on how you look at them. Revit works in millimetres so I imagine the imported data is to an accuracy smaller than 1mm. The building in the shot is about 100m long.

I guess it's something in that. It's weird that MAX can figure out the depth on 2D/orthographic views but not in perspective. Thanks though!
read 2036 times
2/26/2009 6:18:45 AM (last edit: 2/26/2009 6:18:45 AM)
show user profile  advance-software
Move camera near back and far in as much as possible to just cover the range necessary in the camera view - to just prevent clipping.

Not sure if this will affect the perspective view, but it should get things looking ok in the camera view.

Ensure your display mode is set to 32 bit colour.

That should get you a 24 bit z-buffer most of the time.

You might be able to tweak z accuracy in your graphics adapter properties/settings to get a more accurate z-buffer.

> It's weird that MAX can figure out the depth on 2D/orthographic views but not in perspective
Its two different types of projection, so the maths is different.
read 2025 times
2/26/2009 6:58:40 AM (last edit: 2/26/2009 7:05:03 AM)
show user profile  Dejitarujin
I have that kind of issue when the zoom and field of view are unbalanced; ie, zoomed way in with field of view very wide to see everything, or vice-versa. I can't recall exactly, but I think using the "frame selection" button fixes it...
~~~
Specialty: Non-organic modelling and effects.
Setup: 3D Studio 2010 with finalRender.
Rig: No, no I can't.
read 1997 times
2/26/2009 9:33:12 AM (last edit: 2/26/2009 9:33:12 AM)
show user profile  9krausec
Question for you Mr.Bigwilk.... Do you ever or in the past have you ever experienced crashing issues with max while using the perspective viewport? (max is able to save a recover file in autoback, but still is very annoying!!!)... I ask this because you are working on larger scenes and probably have many polygons showing in your viewport at times. If so, what kind of steps did you take to work around these crashing issues?




- Portfolio-




read 1988 times
2/26/2009 10:00:35 AM (last edit: 2/26/2009 10:00:35 AM)
show user profile  bigwilk
Actually no, I haven't. However I don't generally have a huge poly count (<1,000,000 at any rate). I used to have a few problems on my old machine rendering big scenes with Mental Ray dying, but 4GB of RAM + Vista 64 seems to have solved that.

In response to advance-software, I'm on an nVidia card, but the standard control centre doesn't seem to have anything that does the trick, and I don't seem to see this sort of thing anywhere else. I think maybe I'll look for the solution in the export/import process (the way Revit exports means that both sides of a 150mm thick floor will have 2 sides polys, so you end up with identical geometry 0.15m apart, which I presume is what I'm seeing.

Thanks again all!
read 1957 times
2/27/2009 4:04:24 AM (last edit: 2/27/2009 4:04:24 AM)
#Maxforums IRC
Open chat window


Support Maxforums.org