Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(37 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

 
First page  Go to the previous page   [01]  [02]  Go to the next page  Last page
 
How to batch copy multiple modifiers
show user profile  Artie
How to copy a modifier and batch-paste it to multiple objects so that its gizmo would respect each object's volume kind of automatically?
read 1595 times
2/16/2012 2:26:41 PM (last edit: 2/16/2012 2:28:29 PM)
show user profile  herfst1
Not sure. I do know that if you attach an object to one that has a modifier the attached object adopts that modifier as well.
read 1576 times
2/16/2012 3:14:39 PM (last edit: 2/16/2012 3:14:39 PM)
show user profile  Mr.Burns
You can select multiple objects and apply a modifier which will then be instanced. Other than that you might need to do a little bit of scripting.
read 1569 times
2/16/2012 3:52:18 PM (last edit: 2/16/2012 3:52:18 PM)
show user profile  Artie
@herfst1
I want objects to be separate, not attached anyhow neither through Editable Poly nor any other way. The problem is that there are lots of them - i can't just copy/paste a mod from one object to another - it would be a ridiculously slow approach, should be a workaround to kinda batch paste them to a bunch of objects.

@Mr.Burns
Yeah, i know that but if a modifier has a gizmo(my case) and after pasting you select a gizmo sub-object you should see that its volume doesn't fit the object's size, which makes you do a lot of extra tedious work manually resizing that gizmo. Not a good option for me.

Btw guys, do you know how to edit question title in here? I've rushed with posting so that it gets a little bit misleading not exactly matching the content of my question.
read 1565 times
2/16/2012 4:14:26 PM (last edit: 2/16/2012 4:22:18 PM)
show user profile  Dub.
It's really really tricky.

I tried and failed to find a reliable way to do it so it works every time.

One workaround I came up with was to just add 2 extra unlinked verts to the meshes so that they all have the same bounding box. Then you can just copy and paste.


read 1544 times
2/17/2012 6:09:16 AM (last edit: 2/17/2012 6:09:16 AM)
show user profile  Garp
Maybe I'm missing something here but I didn't have any difficulty.
Select the object with the original modifier and type m = $.modifiers[1] in the listener.
If the modifier is in 2nd position in the stack, use modifiers[2], etc.
Then select all the objects you want the modifier applied to and type addModifier $ m
Each oject shares an instance of the original modifier and each modifier has its gizmo conforming to its owner.

And thread titles cannot be edited.




read 1530 times
2/17/2012 8:21:11 AM (last edit: 2/17/2012 8:23:06 AM)
show user profile  Artie
Yes, Garp, this is exactly what i need. Thank you very much!
read 1523 times
2/17/2012 8:31:07 AM (last edit: 2/17/2012 12:06:42 PM)
show user profile  Grap
Hey, there's already two of us. No need to spawn a new one!

*goes order some more lithium*




read 1518 times
2/17/2012 8:35:28 AM (last edit: 2/17/2012 8:35:28 AM)
show user profile  Artie
Hm... i encountered a problem with EditPoly modifier. Whatever i do i can't get the instanced modifier to work. They seem to be instances but never adopt changes while i'm trying to modify a mesh. Just make a simple example - create ten planes, select them all, apply EditPoly or write and execute the code suggested by Garp, it will definitely instance the modifier to the objects but changes made on one won't be passed over to the rest unless you've done copy/paste on a per object basis. How can i overcome that? I really need it. Help me out.
read 1502 times
2/17/2012 3:00:15 PM (last edit: 2/17/2012 3:00:15 PM)
show user profile  Garp
Not 100 % sure but I think you can instance only parametric modifiers, like bend, twist, etc. I mean you can instance an edit poly mod but the changes made to one won't be applied to the others.




read 1488 times
2/17/2012 6:24:04 PM (last edit: 2/17/2012 6:24:04 PM)
show user profile  Mr.Burns
Do you NEED to apply the changes to all objects at the same time? Why not finish one object and then copy the modifier?
read 1485 times
2/18/2012 12:19:52 AM (last edit: 2/18/2012 12:19:52 AM)
show user profile  Artie
In fact, it does instance the modifier but only if i go copy then select another object, right-click in the Modify Panel and choose Paste Instanced. It will work. But i wonder if it works with one object why i can't do the same with other thousands of objects at once. Ok - that 'Paste Instanced' option is grayed out when more than one is selected, but anyways should be a way(maybe a hidden one) to paste an Edit Poly modifier to that whole bunch. Also of note they all have the same poly count but a slightly different shape but it just can't be the reason why it doesn't work 'cause, again, i've managed to copy/paste an instance of the modifier and changes made after appeared on both. But i cannot go that way because there are way TOO many of them. I'd go insane copying/pasting the modifier from one object to another and on and on and end up by 2013.
My boss will lol at me when i tell him how long i'm going to work on the task:)
If somebody's interested i could tell what it's all about.

read 1479 times
2/18/2012 6:09:33 PM (last edit: 2/18/2012 7:30:31 PM)
show user profile  Mr.Burns
If you don't need to apply an awful lot of changes within the edit poly modifier you could script them and apply them to each object that way.
read 1458 times
2/18/2012 7:33:19 PM (last edit: 2/18/2012 7:57:07 PM)
show user profile  khamski
@Artie
>Hm... i encountered a problem with EditPoly modifier...

I bumped at it recently too. But i didn't need a stack in my instances.
So i got back. Collapsed and then instanced. After that i modified not the modifier but the object itself and it worked for me. Guess your case is more complex.


read 1453 times
2/18/2012 7:51:45 PM (last edit: 2/18/2012 7:51:45 PM)
show user profile  Artie
@Mr.Burns
The thing is that i can't script, only nooby like getting a code through Macro Recorder... unfortunately, could not help it so far. The issue is not within the Edit Poly modifier but rather how to instance it to a great number of objects. I might not need to make a lot with this mod but those changes should be definitely transfered to the other topologically identical objects.

Hey, khamski.
Could you tell me what you instanced if you previously collapsed the stack so that there should have been no modifier on top?? Did you somehow turn those objects into instances?
read 1447 times
2/18/2012 8:10:49 PM (last edit: 2/18/2012 8:17:55 PM)
 
First page  Go to the previous page   [01]  [02]  Go to the next page  Last page
 
#Maxforums IRC
Open chat window


Support Maxforums.org