Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography



Maxunderground news unavailable

Animation problem. Dampers on opposing rotation and linkage. Dummies screw it up!
show user profile  jkcal436
The two dampers rotate in opposing rotation. When linking using a dummy Damper1>Dummy1>Linkage and then Damper2>Dummy2>(same)Linkage it screws up the original rotation animation.

read 668 times
8/23/2012 4:32:39 PM (last edit: 8/23/2012 4:33:06 PM)
show user profile  herfst1
Try linking all in one direction so that the rotation of the top damper will carry through to the bottom damper. i.e.

damper 1>dummy 1>linkage>dummy 2>damper 2

P.S. I'm not sure what you're creating so this might be the wrong advice.
read 665 times
8/23/2012 4:37:37 PM (last edit: 8/23/2012 4:39:14 PM)
show user profile  jkcal436
Thanks! I just tried that. It caused the original rotation animation from Damper 1 to change axis and then started rotating along the Y instead of the X (which also happened to both dampers in the original linking scenario).

And no other animation to linkage and Damper 2.
read 660 times
8/23/2012 4:43:20 PM (last edit: 8/23/2012 4:46:06 PM)
show user profile  herfst1
Okay, just tried it and got it to work.

1. I made two boxes representing your dampers and animated a rotation similar to your drawings.
2. Created a bone and put it in place.
3. Created two dummy's and aligned them to each bone.
4. Select and Linked down, like I suggested in my first post and tested... The bone went off at an angle.
5. I put a lookat constraint on the larger bone to look at the lower dummy.

Here's the result (the pic on the right is 10 frames on, I just compiled them in photoshop).



P.S. If this works for you, you can then skin your linkage to the bone. Else, don't bother with the bone and just do this process with your linkage.
read 653 times
8/23/2012 5:00:25 PM (last edit: 8/23/2012 6:53:10 PM)
show user profile  jkcal436
I have tried the bone and the linkage using your advice. I get so far as the linkage moving with Damper 1. But when I get to Dummy 2 and Damper 2.... CRAP! I will continue to work on it!
read 622 times
8/24/2012 12:07:33 AM (last edit: 8/24/2012 12:07:33 AM)
show user profile  jkcal436
Wouldnt you link child to parent? Linkage>Dummy1>Damper1...and then?
read 618 times
8/24/2012 12:22:19 AM (last edit: 8/24/2012 12:22:19 AM)
show user profile  jkcal436
Got it to work! I linked child to parent, animated Damper 1, then animated Dummy1, then Damper 2.
read 617 times
8/24/2012 12:31:42 AM (last edit: 8/24/2012 12:31:42 AM)
show user profile  herfst1
Glad you sorted it out. Rigging is always tricky, I almost always get it wrong the first time.
read 605 times
8/24/2012 6:05:51 AM (last edit: 8/24/2012 6:05:51 AM)
#Maxforums IRC
Open chat window


Support Maxforums.org