Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography



Maxunderground news unavailable

A few questions...
show user profile  Dejitarujin
Time for a few quick questions!

Before MAX 2009 (maybe 2008, I skipped that one), every time a new object was created, it would have a random color. This is one of those things where you never realize how fantastic and useful it is, until it's gone. Now it just picks a random color at startup, and from then on, all objects are the same color. This... is stupid. Fix plz?

Another issue dealing with visibility are the default lights. If I recall correctly, the default lighting used to be attached to the viewport. Which is confirmed by my now-instinctive reaction to rotate the view when working with polygons in a shadow. But now, with the lights stationary, that just gives me a better look at things I still can't see. I'm hoping there's some check-box to fix this... right? (SOLVED!)

One final thing (until I come up with more) should be basic: Saving materials. Multiple times I've had materials in one scene that I'd really, really like to use repeatedly. Probably on multiple computers. In fact, I currently have one such material open. Isn't there some sort of Save To File option? (SOLVED!)

EDIT: I think I'll keep this updated as I find new questions and solutions. Thanks for all the help so far, guys :)

While attempting to install the 1-19-2009 Hotfix, at Computing Space Requirements, I get the following error:

Internal Error 2727.
_8a842a4f_7723_4f55_ad60_5878be92c6b1

"Internal Error 2727" is supposed to mean there's a missing directory, but it won't tell me what that directory is.
~~~
Specialty: Non-organic modelling and effects.
Setup: 3D Studio 2010 with finalRender.
Rig: No, no I can't.
read 643 times
2/22/2009 3:05:15 AM (last edit: 2/22/2009 10:46:44 AM)
show user profile  mrgrotey
1. Click the colour box below the primitives in the create panel and check this box




2. Switch between default light and scene lighting = Ctrl+L


3.You can load materials into different scene directly from the max files. Go to 'get material'-->'material library'-->open-->change file type to .max-->find the file




read 642 times
2/22/2009 3:08:50 AM (last edit: 2/22/2009 3:09:31 AM)
show user profile  Dejitarujin
Assign Random Colors is always on, on all my systems. Just in case, I tried creating objects with it off, too - no change either way. Always the same color it picks at startup, and the color swatch next to the object's name is half black, half white. (I also notice that's not a screenshot of the 2009 color dialog, could that be the difference?)

My scene has no lights created by me, generally until the very end. It's the default lights, once attached to the viewport in earlier versions, that are essentially acting like scene lights now.

The last tip ought to work, though - presumably, I'd be able to make one .max file that's just a collection of useful materials.
~~~
Specialty: Non-organic modelling and effects.
Setup: 3D Studio 2010 with finalRender.
Rig: No, no I can't.
read 637 times
2/22/2009 3:23:33 AM (last edit: 2/22/2009 3:23:33 AM)
show user profile  mrgrotey
>>"I also notice that's not a screenshot of the 2009 color dialog"

Uhh yeah it is, I just made it!




read 632 times
2/22/2009 3:37:11 AM (last edit: 2/22/2009 3:37:11 AM)
show user profile  Dejitarujin
Are you sure? Mine has an extra button, "By Layer" (or "By Object") next to "Add Custom Colors..."

Edit: By "Are you sure" I mean more along the lines of "What's going on here". I trust you know what version of MAX you're using ;P
~~~
Specialty: Non-organic modelling and effects.
Setup: 3D Studio 2010 with finalRender.
Rig: No, no I can't.
read 630 times
2/22/2009 3:42:08 AM (last edit: 2/22/2009 3:47:37 AM)
show user profile  mrgrotey
The by object/layer button is there if you have an object selected before clicking the color box. If you dont have an object selected it wont be there. And yes I know what version I have, 2009 ;)




read 623 times
2/22/2009 3:55:27 AM (last edit: 2/22/2009 3:55:27 AM)
show user profile  Garp
In max 9, when default lighting is set to one light, the light is relative to the view (doesn't change when orbiting the scene). When set to two lights, it's attached to the scene.
Don't know if it's consistent throughout the versions but it was the same in gmax (max 4).




read 614 times
2/22/2009 4:06:58 AM (last edit: 2/22/2009 4:06:58 AM)
show user profile  Dejitarujin
Bingo, that 1 Light switch did it. Guess it's set to 2 Lights by default now. I knew they couldn't have removed something so important ;) That ought to help quite a bit now that I'm doing a bit of organic modelling and can't just rely on numbers to know what I'm doing.

Two down, only one to go. Tried messing around with the colors dialog, switching Assign Random Colors back and forth with and without objects selected, pretty much in any combination I could think of. Still just uses one color. At this point, I'd be inclined to think it's a software error, if it weren't exactly the same on all the systems I've used.

And unfortunately, it seems I can't install the January Hotfix, due to an "internal error". No idea whether it would fix the color issue, bit it does fix (okay, "reduce") the Undo reset glitch, which has been happening a lot!

EDIT: That just became significantly more serious. Using the LipService/LBrush plugin, it will randomly decide not to make sculpting symmetrical. This ranges from simply not applying the brush/tool stroke to the opposite side, to half-applying it in often a different direction. At this exact moment, the Undo stack is cleared, which essentially means I have to start from scratch (or in my case, give up). The two are definitely related, though I'm not sure which is causing which. Either way, getting that Hotfix, fixed, is a top priority now.
~~~
Specialty: Non-organic modelling and effects.
Setup: 3D Studio 2010 with finalRender.
Rig: No, no I can't.
read 595 times
2/22/2009 5:31:10 AM (last edit: 2/22/2009 10:35:28 AM)
#Maxforums IRC
Open chat window


Support Maxforums.org