Forum Groups
  All forums
    Help & Feedback
      Questions
      Work in progress
      Finished Art
      Non-Max related
    Community
      Offtopic
      News
    Hardware
    Photography


Featured Threads
  inspiration alert!!!
(37 replies)
  Indespensible MaxScripts, Plugins and 3rd Party Tools
(37 replies)
  The allmighty FREE Resources Thread !
(17 replies)
  spam alert!!!
(4886 replies)
  Maxforums member photo gallery index
(114 replies)
  Maxforums Member Tutorials
(89 replies)
  three cheers to maxforums...
(240 replies)
  101 Things you didnt know in Max...
(198 replies)
  A Face tutorial from MDB101 :D
(95 replies)
  Maxforums.org Members Gallery
(516 replies)
  SON OF POST YOURSELF
(637 replies)
  Dub's Maxscript Tutorial Index
(119 replies)

Maxunderground news unavailable

Max 2012 - Pivot Point not moving with animated object????
show user profile  peterjung
I have something odd going on here…

I have made an object and animated it simply to move from left to right. However the object pivot point does not move with the object….it simply stays in the position it was in before the object moved?

The object is an assembly of other smaller objects but should this make any difference?

Help!

Here is what I mean:











Unable to display content. Adobe Flash is required.


video working courtesy of Mr Grotey!
read 999 times
2/18/2012 10:04:57 AM (last edit: 2/20/2012 7:58:04 AM)
show user profile  mrgrotey
To embed add another button to jing in the customise buttons window and change the code to 'embed'.

Regarding your problem, I think you are either animating the object at sub-object level i.e. animating the faces/vertices which will not affect the pivot. Or, you have the pivot location set to something other than this...


Grotey

read 986 times
2/18/2012 10:16:06 AM (last edit: 2/18/2012 10:16:06 AM)
show user profile  peterjung
Mr Grotey

Thanks for your reply.

However.

1. Jing

Can you expand some more. I do not understand your explanation. I can add another button to Jing but where is the code to change?

2. Pivot Problem

Animating at sub-object level? I do not think that this is the case but how would I know? When I created the animation I just selected the assembly, moved it and added the required keys.

"Or, you have the pivot location set to something other than this... ".....sorry again I do not understand....can you expand a little?

Thanks for your efforts to help!
read 974 times
2/19/2012 3:58:48 AM (last edit: 2/19/2012 3:58:48 AM)
show user profile  9krausec
@Mr.Grotey- Haven't seen you around the forum for a while! What have you been up to? Oh yeah.. and peterjung's question of course.




- Portfolio-




read 970 times
2/19/2012 4:04:22 AM (last edit: 2/19/2012 4:04:22 AM)
show user profile  peterjung
Actually...in addition there are some other strange things going on...sometimes the transform gizmo shows up in the middle of the object, not on the pivot point?....confused.....
read 966 times
2/19/2012 4:07:39 AM (last edit: 2/19/2012 4:07:39 AM)
show user profile  Garp
Looks like you've moved the objects, not the assembly.
Think of an assembly as being an empty dummy object to which all the objects are linked.




read 964 times
2/19/2012 4:10:53 AM (last edit: 2/19/2012 4:10:53 AM)
show user profile  peterjung
Garp

Thanks...I think I have just worked it out.....

Looks like the animation was applied to two subgroups of objects and then at some time later I made the sub groups objects into an assembly!

Now I see why the pivot behave as it does!

Thanks

Mr Grotey - thanks too...I now understand what you meant by animating sub-objects.... this was indeed the case!

How about embeding Jing videos?
read 960 times
2/19/2012 4:20:11 AM (last edit: 2/19/2012 4:42:25 AM)
show user profile  Garp
Personally, I never use groups or assemblies.
If I want grouping, I'd rather make it explicit by linking the objects to an actual dummy helper.




read 953 times
2/19/2012 4:41:15 AM (last edit: 2/19/2012 4:41:15 AM)
show user profile  mrgrotey
Here's how to set up jing so you cam embed a video...
http://judybrophy.keenecommons.net/2010/06/22/an-easy-way-to-embed-jing-desktop-videos/

The embed button used to be on show by default in the first few versions of jing but for some god known reason they hid it in the later versions.

Grotey

read 940 times
2/19/2012 8:23:13 AM (last edit: 2/19/2012 8:25:27 AM)
show user profile  peterjung
Thanks Mr Grotey!

Got it now!...first post fixed
read 914 times
2/20/2012 7:58:37 AM (last edit: 2/20/2012 7:58:37 AM)
#Maxforums IRC
Open chat window


Support Maxforums.org